cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Pixma MX922 problems

KarenMullen
Apprentice

I have a Canon Pixma MX922 which I LOVED when it was running wirelessly under Windows 7 on my old computer.  Since I've replaced my computer with a new one running Windows 8.1, it doesn't run, it crawls.  If it moves at all.  Occasionally it will print a whole page, but it usually prints a few lines and spits out the half-done page.  It just now literally printed a page out one line at a time--at about half the speed of old dot matrix printers!  What gives?  I haven't changed wireless service--only the OS.

 

 

1 ACCEPTED SOLUTION

jrhoffman75
Legend
Legend
Have you installed the latest driver

http://www.usa.canon.com/cusa/support/consumer/printers_multifunction/pixma_mx_series/pixma_mx922#Dr...

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

View solution in original post

4 REPLIES 4

jrhoffman75
Legend
Legend
Have you installed the latest driver

http://www.usa.canon.com/cusa/support/consumer/printers_multifunction/pixma_mx_series/pixma_mx922#Dr...

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

THANKS!  I thought I had updated the driver, but apparently not.  Having said that, after downloading and installing I now have about 4 versions of the printer showing up in the list when I try to print anything, but I finally found the one that works, and it printed well, so hopefully things will continue happily!  Strangely, the printer that shows up in the control panel is marked "copy (2)" but when I go to print, if I select the "copy (2)" printer nothing happens.  The one that works in a print list is just marked Canon Series MX920 Printer. 

For Karen. 

 

Now that you know the problem was the driver you could delete all the printers and then install the driver fresh. I had to do that when I got multiple copies of my printer. 

John Hoffman
Conway, NH

1D X Mark III, Many lenses, Pixma PRO-100, Pixma TR8620a, LR Classic

Algebravic
Apprentice

I just got my new MX922 a few weeks ago and I love it.  I've been printing photos from my iPhone 6 without problems until today.  I got a new photo which was in black and white (if that makes a difference).  When I try printing it via airprint, the pixma just ejects a blank piece of photo paper almost immediately.  The weird thing is, I can print other photos from my iPhone without problem.  I transferred the photo to my iMac and printed it on photo paper from the Photos app (Incidentally that's the only way I can print on photo paper from the iMac -- I can't find a choice to print on photo paper from other applications such as Preview).  Does anyone have any suggestions as to what the problem might be?

 

Victor

Avatar
click here to view the press release
Announcements