Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Image Class MF654Cdw Document Stuck in Queue


Just joined and hoping someone can help me out.

Dell Desktop Computer

Windows 11

Printer (see subject title)  Wireless setup.

Printer installed.  When I try to print (Word, Powerpoint, etc.) the print window shows the printer connected and available.  When I click on print document it does not print.  It does show the document in queue and says that it is printing.  However, it will not print.  

If you shut down the computer and then turn it back on the document in queue will then print.  I can do this but really don't want to have to shut down and restart every time I want to print a document.

Any help would be appreciated, and thanks in advance.


Rising Star

Could the printer's drivers in the computer be deleted and the latest versions be installed from Canon's website?

For testing purposes, could a temporary Ethernet connection be established between the 654 and the router?

Are there similar problems when printing from other devices?


Went to the Canon website and downloaded the drivers.  Connected the printer to the computer via USB. Copied the driver files but it still won't print until I turn the computer off.

Do any other devices run into the same problem with printing? 🤔


Using the printer at home so the only other device connected is my iphone 13.  Just tried it and it printed just fine.


So the test with the iPhone reveals that the printer is, in and of itself, operational, otherwise the iPhone would have failed to print.

So, now the focus shifts to the computer. There are two more steps that can be taken:

. Bring in another Windows computer to see if it operates properly.

. Default the computer, reload and test the printing capability again.

I think we're getting closer.  Booted up my HP laptop and thru control panel added the Canon printer and then sent a Word document to the printer and it printed correctly.  Now I just have to figure out why the desktop won't work properly.  I have Norton 360 on both machines so I don't think that's the problem.  I'm afraid to delete the Canon printer and then try to reinstall because I had a very difficult time getting it to install the first go around.

One thing I do with both of my personal Windows computers (Microsoft Surface Pro 7 and a Surface Laptop 1) is to backup the printer drivers to my OneDrive account.

If, for some reason, I need to factory default, I can install the drivers right from the cloud. 🙂

If the drivers are being loaded from the Control Panel, I think those are the drivers that come with the unit itself. Canon's website would have the latest drivers.

But anyhow, whatever gets the printer fully functional is the way to go. 🙂


Dexman, I appreciate all the help so far.  I reinstalled the printer on my desktop and it still won't find the printer (via Network Connection) and will install everything but the drivers.  Control panel shows the printer installed but says "Driver is unavailable".  I printed a document from my laptop and it printed correctly.  I made an exception to allow the Canon thru the Windows firewall and turned the Norton firewall off and it still doesn't work. The only difference I can think of is that the laptop is older and is running Windows 10 while my desktop is running Windows 11.  I'm at a loss as to what my next step might be (aside from throwing the Canon out the window and getting a different printer).


Windows 10 works properly. The last test would be to borrow a laptop running Windows 11 and see if it prints properly.

If it does, then a reset of the desktop would appear to be in order.