Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon IJ Print Utility Not Providing Media Information Option


Running MacOS 13 (Ventura), have installed latest CUPS Driver Firmware for Pro-300, have added new media to printer using media configuration tool but when it comes time to update the printer driver to add the new media, the Printer Utility dialogue box does not display a media option for me to update. When I try clicking the option to change, it only displays custom settings and will not let me switch to anything else.

I’ve deleted the driver, reinstalled, deleted the printer, added again, restarted both computer and printer and still have not been able to get the driver to show media information to allow me to update the driver with my new media type I added.


Any suggestions are greatly appreciated, thanks!



I'm having the exact same issue on my new mac with Ventura. On my old mac with Catalina OS, I get the Media Information option in the Canon IJ Printer Utility, but not here. Now I only have the Custom Settings option in the dropdown menu.

After having tried everything I really don't know what else to do.


Confirming that both of you not only downloaded and installed the latest CUPS driver but added the printer in System Settings and confirmed the IJ Series printer and not the AirPrint version?

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

Shortly after I posed this question back in November, I was finally able to get it to work. I don’t recall what the exact issue was but I was definitely downloading the correct CUPS driver and there was something within installation of the driver that was going wonky. The issue was the IJ Series was confirmed but anytime I would open it to try and update media settings, it wasn’t giving that option.

It finally showed up but again, don’t recall if there was an update to MacOS or to the CUPS driver but I’m all square now.


Hi @jrhoffman75

I first installed the printer from the System Settings and then downloaded the latest CUPS driver (version After doing this, on my System Settings now the printer appears twice. One is called 'Canon PRO-300 series' and the other one 'Canon PRO-300 series2'. 

When I click on the first one, the driver is 'version 3.0' and when clicking on Options & Supplies, only 'General' and 'Supply Levels' show up. 
When I click on the second one, the driver is version, and under Options & Supplies there are 3 items.. General, Supply Levels and Utility.

But when clicking on Utility and on 'Open Printer Utility', I only get the 'Custom Settings' in the dropdown menu.

How can I do the last thing you mention? (confirmed the IJ Series printer and not the AirPrint version). Things look different in Ventura and it´s a bit confusing. How can I check if I have the AirPrint version?

On my old mac (Catalina) it shows all the options on the IJ Printer Utility.

Many thanks!

This was the issue I was having too. Responded to @jrhoffman75 but ultimately, it worked itself out but I can’t recall the specifics of what changed to get it working.


I hope you’re able to get it online, sorry to hear you’re having trouble but there is a solution there, hang in there!

The first installed printer is AirPrint; delete that one. The actual Canon driver version is the 24.3......

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

I deleted the AirPrint one and restarted.. but the problem persists. I do not get the 'Media Information' option in the dropdown menu. And without this, when I open the Print Settings in Lightroom, I can´t select 'Manual Feed' on the Paper Source, and I can't select my custom Canson paper on the Media Type.

Can I still print like this? The custom Canson paper shows in the printer´s display (I installed it a long time ago) and I can pick it there before each print, but on my old mac I had it selected on both the printer and the computer in Print Settings.

Hi there,


I'm having the exact same issue- just wondering how you resolved this? I've tried over and over again reinstalling  the correct drive for my Ventura software- but the Canon Utility2 is only showing 'Customs' and not media update. I'm so desperate to get this resolved. Any help to resolve this would be greatly received!

I have not been able to resolve this. Almost 3 months later it is still the same. I can still print, but now I need to set the parameters for the media manually, like I did with my old epson printer.

It's a pity because this was a big advantage to using a Canon printer.