Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Thanks for the update Wallygaw. For now I am happy that spraying with DEOXIT seems to fix it for me without further surgery. I will keep your solution in reserve in case of a relapse. I did notice when the problem first started that it was intermittent and pressing really hard seemed to help for a while -- until it didn't. Now it works just like new.

No problem Dan. Posts on this forum gave me the clues I needed.

eagerly awaiting your results for fitting your flex cable!

The part number is the same in the US- just called canon and its ~ $17 with shipping.

Would love to try to fix it myself, but have no idea where to start, especially if it involves solder :x

I got the part from Canon ~ $18 including shipping. Pay attention to which screw goes where, even though they are all itty bitty, they are all different sizes.


There were six outside case screws, a couple for the top piece that has the power button, etc., a couple for what might be the gps senser (it's a square piece that goes over part of the FPC part), and 2 little ones that are kind of through the FPC piece, but might not have needed to come out as the holes in the FPC may have been big enough to fit over the screws.


No solder involved. The old piece does have some sticky tape holding it down, so it needs pried off that in addition to the 2 slide in connections.


It was a little nerve racking disassmbling and not damaing anything else. My first attempt to power up after reassembly got no power. I hadn't wiggled the FPC connection that slides in the front of the camera far enough in.


Anyway, took a number of pictures at kids soccer game this weekend without issue. Should hopefully be good for a few more years:)

What was the specific part number? I want to make sure that that I order the correct part.

It was the part someone mentioned earlier, CM1-7226-000, description says FPC ASS'Y TOP.


I went through a couple of transfers to get to Parts the first time I called, but it looks like you can get them direct at 1-866-481-2569, 9am-7pm eastern.


It's crazy that a $10 part (much less for them at cost) is causing all of us such angst.


Good luck!

I just ordered the part, with the part number and phone number angeloweb gave. So far so good. Be careful, there are two cameras called S100. The one made 15 years ago is not ours.

I started fitting the part yesterday. The flex and switch assembly are glued to the frame. I used a hair drier to soften it and a knife to lift it off. The flex is destroyed once that is done. I haven't removed the remaining glue from the frame yet, but I think some heat and solvent should remove it. I'm assuming the new flex would need to be heated for re-fitting as well. Fitting the new flex to the large connector looks tricky without doing damage

I didn't heat it. What is there is like a thin 2 sided tape. I did not remove it, and it allowed the new FPC to be held in place.


Yes, the old piece is destroyed peeling it from that tape.

Thanks a lot angeloweb, I'm going to put it back together tonight hopefully, that tip saved some me some potential trouble 🙂
click here to view the gallery