Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575


Hi, I am having the same issue as customers described above. I purchased the camera in the summer 2012 for $360 and a year later the camera would not take any pictures. We called repair department and we were offered two options: send camera in for repair at $160 + $10 shipping fee OR purchase a new camera at a discounted rate (again another way for them to make more money).


When I asked the representative if this was a known issue he said no, when I shared my disappointment as to a camera that cost a few hundreds of dollars should last longer, the rep simply replied "I understand".


I then researched online for similar issues and came accross this forum. Obviously, this is an issue multiple customers are experiencing and I believe this is the responsibilty of the company to keep their customers happy (specially when they are not at fault of the problem).


Due to this response, I opened a claim at hoping this will motivate the company to give a better customer service when the product they sell is not reliable.



Hi - I've joined the forum to add my experience on this topic. 


My wife has an s100 which is exhibiting a similar issue to those described. I put the camera into the video mode and shot a few short video clips. Then I deleted these and went back to the auto mode and was able to take pictures normally. Whether or not this will continue to be the case .. who knows. 


Do you think this points to it being a software problem rather than a physical problem with the camera. Perhaps it could be the memory card as recording a section of video may have moved to use a different section of the card??


I would be most curious to hear if this works for anyone else.




Just wanted to add further support to this case. My s100 is less than a year old and I have been experieing this exact issue for the past 3 months.


What is Canon doing to support users with this issue? From the previous posters' experience it seems that they are not taking any accountability. Which suggests this is a matter to be submitted to the Consumer Ombudsmen.

I also wanted to add support to this case. My s100 is less than two years old and I have also been experiencing this exact issue (shutter release not working) for the past 4 months. We sent the camera in to Canon to fix the other common problem (lense error, lense staying out) and asked them to look at the button but got no acknowledgement on the issue at all. We finally just bought a new camera.



I purchased my S100 in the spring of 2012 for a trip to Ecuador. It worked great the first week, until I dropped it in a museum. Entirely my fault. When I returned to the states, I contacted Canon and sent the camera in for repairs.  They charged me around $120 or so to repair it- cheaper at that time than buying a new one. It worked fine for awhile, then all of a sudden I started having the lens error, in which it would not retract and I could not take any pictures. I took the battery out, etc, etc., but nothing helped. I went online and typed the error message in my browser; that's when I found information about the recall for this problem. When I contacted Canon I was told that my camera was not one of the serial numbers in the recall. Needless to say I was pretty unhappy, particularly after investing another $120 in the camera. I spoke with a supervisor and she was great. She sent me a shipping label and I returned the camera for repairs. They repaired it free of charge. BUT, I was recently in the Yucatan (several weeks ago) and I was using my camera with no problems. On about the third day there, the same problem  with the lens occurred and I could not use the camera at all during the trip. Luckily I had a backup camera with me.  BUT, when I returned to the states, the camera suddenly worked again! Crazy; I have no idea what is going on with it.  I like Canon products a lot and have used them for years, but I am very unhappy with the S100. It's a great camera when it's working. I plan to call customer service on Monday.

same here. Shutter button NOT WORKING ANYMORE.


Canon, come on, this is an ISSUE!


and as the previous users said: Definitely a reason NOT to buy a new Canon Again.

I used the S100 happily for 1.5 years and all of a sudden this annoying issue. I use the S100 for underwater photography so I first though it was my housing. But it’s not. Same problem without the housing.
As one of the previous posters said: it seems to help to shoot a bit of video first and then switch back to photos. Great…


Canon, come on, this is an ISSUE!





I am having the very same problem with my S100 -- the details in other posts don't need to be repeated.  CANON, however, needs to give us an answer.  This is not an inexpensive camera and the problem needs to be addressed.  I'm an experiences photography and have used gear from many manufacturers.


Is there a firmware update?

Same problem here!  I haven't used the camera for almost half a year because of this problem.  I almost sent my camera into for a fix, good that I found this forum before so, else I might just waste my hundred bucks in it. 


I tried the recording videos method and after a few tries with playing back, the shutter does work.  My thought is that the camera actually warmed up, then the shutter button starts to work.  So I proceeded to try turning on the camera for a while, not taking videos, but just toggling the menus and functions, and after the camera warms up, the shutter button works too.  Does any of you have the same experience?


This camera definitely have a design flaw!


Hello all,


After complaining to BBB, here is the reply we received from Canon:



Our office is in receipt of your inquiry to the BBB and it has been directed to me for response. I am sorry to learn that you are experiencing problems with your Canon Powershot S100 camera. Quality service and customer satisfaction are very important to Canon


At this time, may I suggest that you package, insure and ship your unit directly to the attention of our Service Department at the address below. Please include a note describing the problem along with your name and address inside the box. Upon receipt, our technicians will thoroughly examine your model. There is no charge for the examination. You will then be advised of their findings in the form of a written estimate, which would be pending your authorization. Unfortunately, the manufacturer’s warranty is good for up to one year. I am offering a one- time courtesy repair. Please include this letter with your camera.



We look forward to being of assistance to you in this matter and restoring your faith in Canon products.


I am not sure I understand if the repair will be "free of charge" as the term "one-time courtesy repair" is mentioned but also the word "estimate" pending our authorization. I'll have to call in when I have the chance (another hassle).


Hope this will help some of you, by complaining also, they might get the same answer.

I find it interesting that on the Canon Digital Photography Forums, which has a membership 100 times the number of this one, no one has ever voiced a complaint about the shutter not working properly on the S100.


My S100 works flawlessly.:-)

click here to view the gallery