Showing results for 
Show  only  | Search instead for 
Did you mean: 

PowerShot SX70 HS won’t connect to Camera Connect app


I’ve had this camera for about five years and never had a problem. I’m on vacation right now and moved to a different Wi-Fi and it is not connecting regularly. I have gone through multiple different tutorials and tried a lot of things a few times it did allow me to download photos but tonight, nothing. When it was attempting to connect with the phone, the screen was flashing, but no error code was indicated. Greatly appreciate any assistance. 


Product Expert
Product Expert

Hi Birdwoman56,

When a smartphone and camera are not connecting we recommend resetting the wifi on the camera and establish a new connection. Sometimes if the wifi hasn't been reset in a little while it can cause issues like this. To do that go into the camera menu, go to the fifth page under the yellow wrench icon, select Wireless Communication Settings, and then select Clear Settings.

Once you've done that go back into Wireless Communication Settings, select Wi-Fi Settings, and turn the wifi on. When you enable the wifi the camera will have you set a Nickname. Make sure to add or change a few characters so that it is different from the previous nickname. Sometimes if it isn't changed the phone will treat it as the old connection. 

After setting the nickname try these steps to set up the connection:

1) Press the wifi button on the camera and select Connect to Smartphone.

2) Choose Register a Device for Connection and then choose Do Not Display.

3) On the next page you will see a listing for an SSID and a Password. Leave that screen on the camera.

4) On your smartphone search for nearby wifi networks and you will see one that matches the SSID on the back of the camera. Select it and enter the password listed on the camera LCD.

5) Once the smartphone is on the camera's network open the Canon Camera Connect app and it will pop up with a message that it has detected a new camera. Select your camera in the app and when you do the camera LCD will show a prompt asking if you want to connect to the phone. Select Okay and the connection will be established.

The procedure worked just as you described. Photos are currently downloading. I will return to accept this as a solution after I had the opportunity to Download Photos another time. For the last week it would work occasionally and then not work the next time. I’m really hopeful that this has resolved it and I so appreciate your help

I ended up purchasing a new XS 70 HS as there were other issues in addition to the problem connecting with the app. So I have the new camera set up but I have to go through the entire procedure provided in the solution here. Every time I want to transfer photos this was never true in the past. I’m looking for additional solutions, please. Thanks for your help again.

After writing that last message, I am attempting to download photos. I took today. Going through the whole process. I reach my photos but the photos taken today are not there to download. They are on the camera, but I cannot access them through the app. Yikes!

Product Expert
Product Expert

Hello Birdwoman56,

I would suggest resetting the wireless settings on the camera to factory defaults and establishing a fresh, new connection. You can set it so that the camera acts as the access point instead of having to worry about having WIFI access at any given time. I have included an article with instructions to set that up HERE.

I went through this process, and it appeared to be prepared to allow me to import pictures. But then the camera did not go to pictures. Upon investigation, I found two things. Where the camera shows up under my Wi-Fi net work, it was telling me I needed to reset the modem, although the modem was working, just fine with update devices in the house. Also, 4000 pictures on my card seem to have disappeared and they are the lifeline of my business! At my wits end now.