Showing results for 
Show  only  | Search instead for 
Did you mean: 

Cannon Ixus 82IS I cant download any pictures


Ive spent all day trying to sort out why my comera wont download pictures and still none the wiser. It was fine yesterday then today I plugged in the usb cable turned the camera on and slid the bar on the right side where the menu etc is and which changes the camera into taking Pic - Videos - Downloading, and nothing happened. Normally a yellow light flashes near where it says Cannon and then a screen comes up on the computer giving me options but this didnt happen and the computer went to picture library and thats where it still is after 8 hours still importing files. Ive checked the USB in different ports but the same problem, ive updated the USB drivers but nothing and generally done everything it says on the computer when you cant download pic. I did plug the USB cable into my Husbands laptop and everything worked fine but tried on mine and im still in picture library and it says its importing files, why or what ive no idea. I did think about updating the software and drivers but it says it doesnt need it as once the camera is connected to the computer it will recognise it but it doesnt and now it doesnt show up in devices connected to the computer.



So its working on one computer in the house, but not another?  

So its probably safe to say there isn't a problem with the camera, card or cable.  Maybe a recent system update has caused the problem.  If you are using a PC, you can use System Restore.  If MAC, Time Machine and revert the system to a point in time where the camera worked.

Another option is using a card reader which bypasses the software all together.  Camera technology has improved greatly in the 18 years since your camera was released.  Maybe its time to consider treating yourself to a new device.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10

~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw ~Pixel 8 ~CarePaks Are Worth It


Agree with Rick on both counts - the issue is likely with your operating system on the computer in question.  First thing, if you have not done so already, is to do a system restart on that computer.  Very often, if a system has downloaded any updates, connectivity is screwed up, but a simple shut down and restart may solve your issue.

Definitely consider simply removing the card from your camera and using a card reader (built-in or USB connected) to connect the card to your computer.  I should see it as an external drive and then you just follow normal procedures to copy the contents of the DCIM folder to wherever you want on you hard drive.

cheers, TREVOR

Before you ask us, have you looked in the manual or on the Canon Support Site?
"All the variety, all the charm, all the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris
Enter for a chance to win