cancel
Showing results for 
Search instead for 
Did you mean: 

mb2700 printer install fails on Windows 10: "new port could not be created 0001"

rcheetham
Apprentice

I'm having trouble with an MB2700 printer on an Acer laptop running Windows 10. I couldn't access the printer any more, so I went to reinstall the drivers etc., and when I attempt this, it always fails with the error message: "New port could not be created 0001".

I tried uninstalling the printer, and then uninstalling all of the Canon software and drivers, restarting, and then reinstalling from the CD which came with the printer. I got the exact same error message.

I searched on here and saw that this is an error reported with older printers, and those have a utility program to force release of the ports. I looked on the MB2700 disc and unfortunately there is not one of those - at least not that I can see.

The installation program reports that the MP Drivers could not be installed, and suggests I click [Start over] to reexecute the installation process. I did this - it doesn't help, and I get the exact same error again. (Also it is annoying that this program gives me no option to quit, but that's a small problem compared to being unable to use the printer.)

Any tips or suggestions? As it stands, this printer is unusable.

2 REPLIES 2

rcheetham
Apprentice

Anybody?

Hi, rcheetam!

Thanks for posting on our forum! This community is designed for your fellow Canon owners to help each other out with any problems they may encounter. If this is a time-sensitive matter, click HERE search our knowledge base or register your Canon gear HERE to access additional support options.

Thanks and have a great day!

Announcements