Showing results for 
Show  only  | Search instead for 
Did you mean: 

macOS v11.2 Big Sur


I've recently upgraded to macOS Big Sur v11.2 and I'm trying to print to an ImageRunner Advance C7565i III. When I attempt to install the recommended driver, I receive the warning "the following disk images couldn't be opened: UFRII_v10.19.7_Mac 2.dmg; Reason: image not recognized". Repeated attempts yield the same result.


When I tried using the (earlier) 10.19.6 driver version, the installer will open, but I get the message "Cannot install on this version of the operating system you are using".


I wonder if I'm the only one having this issue.



Hi, longt!

Thanks for posting! While our forum community members are welcome to chime in, Canon does not provide direct support for imageRUNNER series products. Instead, your dealer will be able to help you! If you don't have a dealer and you're in the United States, please call us at 1-800-OK-CANON (1-800-652-2666) and we will be happy to provide you with the names of dealers in your area.

If you're outside the USA, visit and choose your country or region from the map for local support.

We hope this helps!