Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mf628cw stuck at data light blinking


No function works. Updated FW.  Turn on/off multiple times. Reset to factory default. Plug in/out from electrical outlet.


Tried to copy 1 sheet.  Does not copy. Just makes noise for 2 min and then silence and the data light keeps blinking continuously. WiFi light solid blue.  No error light.


What is going on.  This is irritating.


Can someone help



Hi Api22890,


If no message is displayed, print recieved document or delete unnecessary documents in the memory.


You can also check:

1. Remove any jammed paper or document in the printer.

2. Check the Paper Size & Setting Mismatch settings.

3. Delete any print jobs. You can also power off print and discount power cord for 30 seconds. Reconnect power cord and turn on copy.

4. Remove and re-insert toner cartriges.

5. Replace Toner Cartridge(s).


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I am having this same issue; it has appeared recently despite the fact that the printer has been in use for well over 2 years.


The green light will not stop flashing after it prints a job unless the printer is powered off.  There is no error message appearing on the screen nor is there an error light flashing - just the green "Processing / Data" indicator.


There is no jammed paper, mismatched paper settings, print jobs to delete in queue.


I have deleted the drivers and software from Windows, restarted the computer, reinstalled the driver and software (Scangear) but this has not resolved the issue.


I am running the current latest version of Windows 10 with the latest Canon drivers installed.  As previouisly mentioned, this printer has been working fine; this problem started within the last month (Feb 2020).  I am running a wired eithernet connection to the printer.  I can manage the computer settings using a browser and the printer's IP address but that provides no apparent solution to whatever is causing the problem.

One other thing to note - once the light starts incessantly blinking, nothing will print.  If I attempt to print, I can step through the printing windows that open in the application I'm working in and the application appears to accept the print job.  However, when opening the print queue, nothing actually appears in it.


If I check the LCD display on the printer itself and look at the "Copy/Print Job Status" listed under the "Print Status" button, the print job DOES appear but shows to be "Paused".  There does not appear to be a way to "continue" the job since it's not showing up in the Windows print queue though.  "Pause Printing" is NOT selected in the Windows print queue either.


If I power down the printer when it's in such a state, it powers back up with the light staying off (after the initialization process) and the paused print job no longer shows on the LCD screen.  I can then print ONE job again before this entire error state starts all over again...

A few more things I've tried since the previous posts...


I completely reinitialized all settings on the printer and verified this occurred.  Afterwards, I updated the firmware directly from the printer itself and that also worked.  But after rebooting after the firmware update, I was confronted with the blinking green "Data / Processing" light immediately.  Only after turning the printer off, unplugging it, turning it on (while unplugged, the screen came on momentarily), turning it off, plugging it back in, and then turning it back on did I get it back to what should be its normal mode (no flashing green light).  I was then able to print one document (this time from Word, but it doesn't seem to matter what application is issuing the print command); following the successful printing, the green flashing light was on once again.


I initially thought this problem was being caused by something that changed in a Windows 10 update, but now I'm less sure.


I've had this issue a number of times over the years and it's super frustrating!! 

After a few days and long hours I'm finally able to fix it- but then 6 months later when it happens again I forget how I fixed it lol
I do remember that it has something to do with the toner cartridges.  Specifically if you don't use canon brand ones.  One time I did call into customer service and she had me remove the toner cartridges, power off/on then add them back in one at a time powering off/on between each one.

Totally random but hopefully one of the lucky toner remove/replacements and power on/off will magically work.  I wish the machine wasn't like this- 99% of the time it's fantastic, but this hiccup is a time suck to fix.