Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF8580cdw loses network after a while?


We have a MF8580cdw connected via wifi, with a dedicated IP address assigned by the router based on the MAC address.


We're having an issue where the printer cannot be found on the network after a while, and nobody can print.  The only solution we've found is to hard restart the router (unplug, count to 30, plug back in), and then turn the printer off and on again.  After that, printing works again.


We are using a mix of Windows XP and Windows 7 computers--all computers have the right drivers installed and can print when it is working.  Nobody else has any connectivitiy problems with the same router in the meantime, it appears to only be the printer.


Thanks in advance for any help!



Hi heybink.


I will be glad to assist you with the imageCLASS MF8580Cdw.


Since the units stops working after awhile, it indicates that the units is set to obtain an automatic IP address.  This means that the IP address will change periodically and may cause the unit to stop working.  I recommend setting a static IP address and this will normally fix the issue.  I recommend uninstalling and reinstalling the drivers after setting the manual IP address.  Please follow the instructions below to set the static IP address:


  1. Click the Windows [Start] button, and then select [Devices and Printers].
  2. Right-click on the MF8500 Series icon and select [Printer Properties].
  3. Click on the [Ports] tab, and then write down the IP address of the selected port. (You may need to click on "Configure port".)
  4. Click the Windows [Start] button, then type "cmd" in the [Search] Box and hit [Enter].
  5. In the Command Prompt screen type "ipconfig".
  6. Write down the Subnet Mask and Gateway for your network.
  7. Go to the printer and press the [Menu] button.
  8. Scroll to [Network Settings], and then press [OK]. 
  9. Scroll to [TCP/IP Settings], and then press [OK]. 
  10. Scroll to [IPv4 Settings], and then press OK. 
  11. Scroll to [IP Address Settings], and then press [OK]. 
  12. Scroll to [Auto Acquire], press [OK], scroll to [Auto IP: On], and then press [OK].
  13. Scroll to [Off], and then press [OK].
  14. Highlight [Apply], and then press [OK].
  15. Scroll to [Manually Acquire], and then press [OK].
  16. Select [IP Address] and enter the IP address you wrote down in Step 3.
  17. Press [OK].  Do the same for the Subnet Mask and Gateway Address, and then press [OK].
  18. Press the [Copy] button to exit the menu.
  19. Now turn off the main power on the lower left hand side of the printer for about 10 seconds and then turn the power back on.

I hope this information is helpful to you.  Should the error persist, or you need further assistance, please contact us at 1-800-OK-CANON (1-800-652-2666).


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I am also facing the same problem. I want to be able to control the IP address from the DHCP server by assigning it statically there rather than on the printer. This lets me control addresses at a network level. There appears to be a bug in your implementation of the DHCP client on the printer that does not renew the lease correctly. Any chance this can be corrected?





What is the equivalent solution when using a Mac?


I have exactly the same problem.

This has become worse over time... I now have to restart the printer several times before I can connect to the admin panel.

Computers now, do not see the printer for most of the time, the router shows the correct DHCP lease to the printer.

This is beginning to be really frustrating.

I see that people have posted additional reports of the same problem, without any additional help.

It would be nice to get this fixed, so that I can then start to work on the problems with cloud print.

I believe I have found a solution, but it is a little complex and I am traveling at the moment so I can't refer to the various menus I went through.  On the printer I went through various menus to first determine the current IP address and then through some more menus to a place that allowed me to set that address as the permanent address for the printer.  On my network router, I did a similar thing, reserving that address on the network for the printer.  At first I did only one of those (sorry, I can't remember which I did first) and it worked really well for a while but then it didn't.  It's been a couple of weeks since I've done both of the settings and it has been really consistent even when I go for days without printing or, as I had to do recently to accomodate some work in my house, when I've unplugged and restarted my modem/router.  Good luck.

Sorry, meant to post a reply ages ago.

I set the IP on the printer, which seemed to work fine (but I did not test for long).

I then set the IP for the printer on the router.

My guess is that it should be fine if it's only done at the router, but setting both places does not hurt.



Thanks for your input,

I recommend setting a static IP address and this will normally fix the issue.  I recommend uninstalling and reinstalling the drivers after setting the manual IP address. for more info you can refer to this post here

click here to view the gallery