Canon Community Canon Community

New Contributor
Posts: 3
Registered: ‎01-11-2019
Accepted Solution

MF8380CDW Printer not found by driver installer

[ Edited ]

I'm trying get the MF8380ZCDW office printer working on this Windows 10 Dell laptop.  Basically, I download the driver from here:


I run the driver .EXE installer, and select "Network Connection (for Network Models)" and click "Next".  The installer then searches for the printer on the network, but does not find it and gives a message "Device is not found".


Things I have tried:

1.  Set the IP address manually on the printer to  Set the IP address manually on the laptop to  Run an Ethernet cable directly from the printer to the laptop.  Confirm the laptop can ping IP address

2.  I've clicked "Search by IP Address", and manually typed in  But the same error comes up "Device is not found".

3.  I've clicked "Search Options" and set the search time to "Long".

4.  I've disabled the Windows firewall on the computer.

5.  I've removed all Canon software/drivers from this laptop, rebooted, and trying it all again.


I know the printer works, because I have another Windows 10 laptop that discovers the printer just fine with the same driver installer executable.  The problem is there is absolutely no troubleshooting information beyond "Confirm network connection and device is on".  Well obviously I've done all that, and it just won't find the printer.


What exactly is the driver installer doing when it is "searching" for the printer but can't find it?  I can ping the IP address from that same computer, so I know it's there....


Product Expert
Posts: 622
Registered: ‎09-30-2013

Re: MF8380CDW Printer not found by driver installer

Hi deltamind106.


Based on what you described, I will have to recommend that you call us. I understand that the forum may be the preferred method of communication, the real time feedback of a live technical support call would be very beneficial in this case.


Please call 1-800-OK-CANON (652-2666), Monday - Friday 10:00 a.m. to 6:30 p.m. ET (excluding holidays). 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 3
Registered: ‎01-11-2019

Re: MF8380CDW Printer not found by driver installer

Well that was worthless.  After being on hold for 45 minutes waiting for someone, they basically said sorry your printer isn't the problem since other machines can access it, so the problem must be your laptop.  Thanks for playing, please play again soon!  I tried asking them for troubleshooting information on what the installer is trying to do when it "can't find the printer", but no answers.  After a bit of convincing, I finally got the guy to tell me what TCP port number it uses (9100).


Customer service grade:  F

The person on the other end could not help in any way troubleshoot the problem, and I finally gave up.  I guess I will have to wipe the disk and re-install the operating system.  Fu(king bullsh!t.

New Contributor
Posts: 3
Registered: ‎01-11-2019

Re: MF8380CDW Printer not found by driver installer

After installing Wireshark network packet sniffer, everything the guy told me seems to be incorrect.  The only bits of information I got from him was that:

    a)  It uses TCP (as opposed to UDP)

    b)  It uses port 9100


Well both were incorrect according to Wireshark.  The reality is:

    a) It uses UDP

    b)  It uses port 161 (the standard port for SNMP communications)


Could customer support be any less helpful?  It's like pulling teeth to get any information, and now it's clear why:  because they have no fu(king idea what they're talking about.  They're less than worthless.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement