Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF4780w Scanner not installing on WIndows 10


Hi there, 

I have been emailing Canon support regarding this issue and they have been very helpful. However, I am still unable to use the scanner on the MF4780w since upgrading to Windows 10. There was no problem on the previous Windows version.

I have installed the drivers & MF Toolbox, attempted using Windows Scan App, uninstalled and reinstalled drivers and toolbox, and still no scan use. The printer is fine.

Canon's last reply was to open select Scan, remote scanner, then open MF toolbox and choose the scan option.

This bought up an error reading saying 'a supported scanner is not installed' as shown in the first photo.

When uninstalling and reinstalling, another error came up stating 'Can't create output files'. 

Is the second error reading related to the first, I am wondering!


This has been ongoing for over a month, and the scanner is needed. I decided to make use of the forum as it may open up some further suggestions as to what is missing.

Many thanks in advance



Hi there, this has now been solved. It was possibly related to Google Chrome. A colleague uninstalled and reinstalled Google Chrome and this has enabled the scanner to work. This may not be the only solution, though it appeared to work here! Regards, Glass1


I  also have a similar problem as the scanner does not funtion anymore and yet the printer and fax work ok although it has worked perfectly since the orignal installation when I upgraded to the free update for Windows 10.However about a month ago the toolbox displayed the following error message:

" A supported scanner is not installed. Please install a supported scanner and then restart"

I can install the toolbox driver and overwrite any previous versions but the scanner still has the error message.

I have uninstalled both the printer and driver quite a few times but with no success.


Cannon have also tried to assist, plus our IT guy, plus the local technician in my part of the world but it still does not work.

 I tried uninstalling Google Chrome but that did not help either. Hopefully someone has a solution?


I had the same problem. So I setup my scanners to scan to a SMB folder on each computer.


Here is a video demonstrating how to set the Canon to scan to a SMB folder.


Hope that helps