Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF451dw Stopped Printing from Computer with UBS Connection


Printer will work to scan and copy but not print via desktop computer.  Printer will print connected via laptop, iPad, or iPhone and wi-fi network  but not via UBS cable.  Have reloaded driver and changed cable.  Printer is only a month old and printing worked via cable until yesterday. Are there some kind of preferences that need to be reset.  Have tried setting up UI with desktop but no luck. Initial set up disk was worthless and only show a picture of my Printer and it’s model number.  No other set up instructions.  Manual on line is 600+ pages and a two page color map of all of the printer screen icons.  Worthless.  Too small to read and says I can print it off but kind of tough to do as printer does work and would not be color anyway.  This map screen icon map looks more like what a Canon engineering or technician might use.  Other ideas?


Product Expert
Product Expert

Hello PTH,

We would be happy to assist with the issue. To provide some feedback or some troubleshooting steps, we would need some additional information. If you could reply to this message with the information below, we can provide some assistance. For a more immediate resolution, you can contact support over the phone at 1-800-652-2666.

  1. What version of the Mac or Windows operating system are you using on your computer?
  2. When you try to print from the computer, do you get an error on the computer or printer display?

Hector, thank you for responding.  My desktop has Windows 11 Pro as an operating system.  I do not get an error message on my computer when I try to print.  I hear a small click at the printer and see a que on my screen of items to be printed.  Nothing else happens.



Product Expert
Product Expert

Hello PTH,

If the jobs are staying in the print queue on the computer and you do not get any error messages on the printer or computer, it might be an issue with the printing system. You can try restarting the print spooler service on the computer. 

You can press the Windows key and the letter R key at the same time on your keyboard. In the run box that appears, you can type in services.msc and click OK. In the window that comes up, you can try highlighting the print spooler service in the list and then click on the option to restart.

If that does not resolve the issue, I would suggest contacting support over the phone and they can check what is causing the problem with the jobs staying in the queue.



Any resolution to this issue? I am having the same problem.  Thanks!

Stephanie,  I have spent hours trying to solve the problem.  Have tried new startup disc, resetting of printer preference including changing computer connection from WiFi to UBS cable.  Never have gotten the UI on computer to work.  Using AirPrint from iPad gives me a larger print font than wanted.  I have about given up, but will try Canon support one more time.  Their phone number is 1-800-652-2666

Thank you so much for responding. So sorry to hear that you haven't had any luck getting appropriate support from customer service.  That is disappointing.   I will contact Canon as well and let you know if I have any luck.  The USB worked for about a week, then it wouldn't connect at all! So frustrating...


I called Canon support and we got it working!  It had something to do with Windows 11 and the print queue.  I was told this is common with Windows 11.  Call the support center!  They will get you up and running!  Thank you !


03/30/2023: New firmware updates are available.

EOS R3 - Version 1.4.0

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

03/28/2023: New firmware version is available for EOS-R5 C
03/14/2023: New firmware version 1.8.1 is available for EOS R6
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.