Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

I did what too but still can not scan remotely. Help from Canon would be highly appreciated.


Apparently what I did earlier only worked until I restarted my computer.  I can get it to work by going through the same process over again so not really a solution.


This simple fix I found online worked for me:


Start> in the run box type. Services.msc

Scroll down to Windows Image Acquisition (WIA)

Right click, select Properties

Check that Startup type is set to Automatic

Click Log On Tab

Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.

Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply.

This worked great for me also Piers-A..thank you

That's good to know thanks.  Easier than buying a new printer!

I just lost the short cut to the mf toolbox.  I decided to uninstall alll the drivers as well as the toolbox.  The drivers loaded but when I try to download the MF toolbox software it says "Canon says Error"


I am runnning windows 10 on a 64 bit desktop.   Help!!



@Orthowork1 wrote:

I just lost the short cut to the mf toolbox.  I decided to uninstall alll the drivers as well as the toolbox.  The drivers loaded but when I try to download the MF toolbox software it says "Canon says Error"


I am runnning windows 10 on a 64 bit desktop.   Help!!




Follow James' instructions above again. Install the printer drivers first and make sure the printer is working, then install the MF Toolbox app last.


My Canoscan 4400F used to work with Windows 10 but after an update it stopped.  I followed these instructions which then allowed it to scan again.   I don't know who the author is so can't credit them but here's their website.



I have a Canon CanoScan 4400F Scanner and the other day I was unable to get it to work.  I use the Canon software CanoScan Toolbox to operate the scanner and when trying to scan I was getting the following error message:


CanoScan Toolbox
Unable to open TWAIN source
Please check connection
Then re-start Toolbox

Searching the Internet for this problem turned up several people having the same problem and several solutions which looked like they may or may not work.  One of the recommended solutions was to make sure a certain folder path is in your PATH environment variable.  As it turned out this was the problem, so here is how to add that path back into your environment variables.

First, determine the correct path to add into the PATH environment variable.  Look in C:\Windows\twain_32 and there should one other folder in there.  In my case it was  named CNQ4803.


This is the path that is needed to be added into the PATH environment variable.


Now, follow these instructions to get to the dialog to modify the PATH environment variable.

Control Panel > System > and then choose Advanced System Settings in the left hand column.


This will bring up the System Properties dialog (it should already be on the Advanced tab).


At the bottom of this dialog is an Environment Variables button.  Clicking this button will bring up the Environment Variables dialog.


In the bottom panel, scroll until you find the variable named Path.  Select this one and then hit the Edit� button to bring up the Edit System Variable dialog.


In the Variable value text box, scroll all the way to the right and then add in the path C:\Windows\twain_32\CNQ4803 that was determined earlier.  Make sure to separate this value with a preceding semi-colon.  And also be careful not to make any other changes to this value.

Now OK your way out of all of the dialogs and CanoScan Toolbox will now work as expected.

Don't know but if I were Cannon administartor I would move this to number1 spot...


All the others including mine are useless if these setting aren't correct hopefully everyone reads this one first...


A big thank you to Piers_ACapture.JPG

I again went through all of the motions (and emotions) but to no avail.  The toolbox will not install on my windows 10 pro.



My printer/scanner is a D420.  Maybe the work around works on some scanners and not others??  Seems like Canon needs to get on the ball.