Showing results for 
Show  only  | Search instead for 
Did you mean: 

Internet Explorer crashing when trying to print (sorta?)




I work for a school and am having a really weird and annoying issue with trying to print to an imageRUNNER 7095. Our domain workstations are all Windows 7 and IE10.


Some users are complaining about not being able to print to the copier. I have observed the issue: users would try to print from within IE10, select the copier, select print, and then the Department Code & Password dialog box would appear. Upon getting this dialog box, IE would hang. In some instances, I could drag around the department code dialog box and get a hall of mirror effect and I couldn't use IE until I manually terminated it. Not all users experience this issue, as some can seemingly print to the copier just fine.

For the affected users:


  • I've tried removing the copier from their printers and then reconnecting to it.
  • I've tried restarting the print spooler and clearing the queue where there was one.
  • I've tried deleting all drivers in system32\spool\drivers and reinstalling the printer fresh.
  • I've tried updating the driver to the latest version (ver 14 PCL5e)
  • I've tried adding a separate instance of the copier using the PCL6 driver.
  • I've download a printer-spool-reset-to-default FixIt/PS1 and resetting everything back to zero.
  • I've uninstalled and reinstalled IE10.
  • I've tried turning IE10's dump file feature so it will spit out a dump file when it crashes, but it doesn't spit out anything--presumably because IE10 isn't actually crashing and is just hanging?
  • I've run SFC (System File Checker) and chkdsk and even a HDD surface scan.
  • I've verified that the printer driver files' hashes match the same as an unaffected computer's.
  • I cannot figure this out.

Anyone have any ideas?


Pretty much the only thing I have figured out so far is a way to reproduce something approximate to the error both on affected machines and non-affected ones. I'm going to describe it as exact as possible as deviating from this script in even minor ways can cause this particular behavior to not occur:


  1. I log into a computer on the domain.
  2. Press Windows-R to bring up the run menu.
  3. Type in:  iexplore about:blank
  4. Once IE10 loads, press Ctrl-P.
  5. In the print menu, press Alt-P to confirm printing (the iR7095 is the default printer).
  6. The department code dialog menu pops up wanting a code and password.
  7. I wait approximately 5 seconds.
  8. The department code dialog menu disappears.
  9. Internet Explorer 10 is now unresponsive.

Once I get to this point, I've discovered that I can "un-hang" IE10 by opening up anything else and then minimizing it. For instance: I press Windows-E to open up Explorer and then I click minimize on the new window. Now the department code dialog box returns in the IE10 window (as if it was just minimized somewhere) and I can put in a code and print.


This particular reproducible issue only seems to happen when I try to print from about:blank, however, so I don't know if it's entirely the same issue that users are experiencing when they try to print out their grades or something. I haven't verified that opening a new window and minimizing it fixes their issue yet as I only just now discovered this.


Anyway. I hope someone out there has some ideas about this because it's really frustrating. The only thing I've been able to tell affected teachers at this point is to not print to our giant Canon copier and to instead use their super expensive inkjets to print out their heaps of grade reports... Smiley Mad



Hello itangir,


Thanks for posting! Canon does not provide direct support for imageRUNNER series products, but your dealer will be able to help you! If you don't have a dealer, please call us at 1-800-OKCANON (652-2666) and we will be happy to provide dealers who are in your area.

I'm also seeing this issue. We have a batch of new IR5000 and IR7000s with Fiery controllers. The batch before this didn't have the issue. Now the printers will randomly lock up and require a reboot to bring it back online. This is happening across multiple machines. We are still using a combination of the A1/B1 and are slowly migrating to the A2/B2 drivers. All of them print fine but wondering if the old drivers are part of the issue. One thing I'm looking into is the old printers were served from a 2008R2 PServe and the new ones are being served off of 2012R2. Considering the driver isolation options as a potential fix. I also think our firewall filtering may be an issue. We filter lots of content and that can hang IE when it tries to render content for the print job. Printing works fine, but any content heavy site such as lags or stalls because of all the content those type of pages load up.

Would love to know if you found some good info. A suggestion to Canon. The "Hey we just make it, talk to the people that sell it for support" does not build customer loyalty or confidence.
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.