Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error: remove tabs/pieces MF624Cw


Bought nre magents toner and installed. Have done several times before on other colors with this printer. Removed plastic tabs and pulled out strip. Printer gives error message "Remove tabs/pieces of tape from the toner cartridge. Magenta (M)" Which I have already done. Turned off and reooted, still no change, HELP!


Have you removed and reseated the cartridge?


If so, and you still get the error, I'd look carefully at the tabs to ensure they were removed "cleanly" with nothing left behind.  Also ensure the tape was completely removed.  Pulling at an incorrect angle can leave a piece behind making the printer "think" the cartridge hasn't been prepped for install.   

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring

~6D2 (v1.1.1) Retiring ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It

Thanks for your quick reply. Trid all that and still have same problem. Could not locate any plastic peices that didn't come off nor any of the film. Still has error message!


Try unplugging the printer for a few minutes.  Plug back in a power on.  Then reseat the cartrigde again.  If you continue to have issues, you may want to try another cartridge (yours could be defective) or contact Canon.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring

~6D2 (v1.1.1) Retiring ~EF Trinity, others ~DxO PhotoLab Elite ~Windows10/11 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~CarePaks Are Worth It


I am having this same issue with my MF8280C. I have only used OEM Canon catridges. When I bought and replaced my Magenta cart several weeks ago, I put the new one in and got the same error message.  I tried everything, but it wouldn't work, so I returned the cartridge and ordered a new one.  It worked for several weeks until yesterday.  We lost our electricity for several hours, and when it came back on, the printer gave me the Remove tabs/pieces of tape error on the Magenta cartridge again.  I hadn't opened the door or removed anything since it was replaced weeks ago.  I rebooted, unplugged, removed and cleaned everything, but am still getting the error.  I don't know if it's the printer or the cartridge, but I'm not willing to shell out another $70 to replace the cartridge AGAIN.  This issue is surprisingly common and VERY FRUSTRATING.  

Product Expert
Product Expert

Hi BroChester,


The sealing tape on the toner cartridges is still attached. Remove the sealing tape.

1.  Open the front cover.

2.  Pull out the cartridge tray.

3.  Pull the toner cartridge straight up and out of the machine.

4.  When pulling out the sealing tape -

If the sealing tape remains inside the toner cartridge, the quality of printouts, including faxes, may deteriorate. Also note that it will not be possible to reprint a fax because the fax function automatically deletes data once it is printed.
Do not pull out the sealing tape at an angle or sideways. If the tape breaks, you may not be able to pull it out completely or wll receive an error.
If the sealing tape becomes stuck when pulling it out, keep pulling until it is completely removed.

5. The drum protective cover should be removed.

6. Re-Install the toner cartridge.

7. Push the toner cartridge tray back in, and close the front cover.


If the message still appears, please replace with Canon Geninue Toner Cartridge.


If the message continues, please check for any Firmware Updates on the Canon USA Drivers & Downloads website:


You can also check version and update on the the imageCLASS MF624Cw operational panel. the printer has to be connected to the internet.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I disagree with this response.  I have had this happen 2 times in a row with Magenta OEM Canon carts. I know how to prepare the cartridge. I have done it literally hundreds of times. Becuase I had the same issue with the same color cartridge and no others I decided to by a knock off cartridge just to see if it would work before taking my printer iin for service or buying a new one.  The cheap knock-off cartridge worked immediately.  The quality isn't great, but it worked whereas new $75 OEM Canon didn't work 2 times in a row. 


Also - on my second failed OEM Cartridge, it worked fine for a few weeks until we lost our electricity for 2 days.  When it was restored is when I got the error message.  I tried all of the unplugging re-seating tips as before, but nothing worked. I'm pretty sure the sealing tape didn't mysteriously insert itself back into the cartridge. But seriously, I think there are defects in the OEM cartridges.  For it to happen 2x in a row seems unlikely to be a random occurance.  

After my cheap knock-off cartridge was finally empty. I decided to buy another Canon OEM cartridge (at a staggering $90). Everything was fine. Print quality excellent. 2 days later, THE SAME ERROR MESSAGE appeared again on the magenta cartridge.  I put the knock off back in and no error message.  I'm done with this company. It is ridiculous how many times this has failed and the only advice on here is to remove the tape. REALLY?  I have owned Lexmark, HP, Epson, Minolta, printers and never had an issue like this.  What makes it worse is that I paid more for these defective OEM cartridges than I paid for the printer.  If anyone is interested in BRAND NEW 131 carts, let me know.  I have an unopened Blue, an unopened Yellow, and this Magenta cart available.  After three times, it is more likely the printer than the same color cartridge every time. The printer is going to the dump where I should have taken it a year ago when this first started happening.   

03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.