cancel
Showing results for 
Search instead for 
Did you mean: 

Color Imageclass MF644cdw Not Found on Mac using Wireless Connection

kep
Apprentice

I have owned this printer for about one year.   I set it up and it was working but every time I try to print using the wireless Lan option, the printer can not be found.  I usally figure it out but to be honest, in the year I have owned this printer, it has not worked most of the time.   A week ago I downloaded the new drivers and I was able to print.  Now once again the printer cannot be found.    I have reconnected to my wifi and I have downloaded the drivers again.  

 

Please help.   

 

Many thanks,

 

kep

7 REPLIES 7

shadowsports
Elite

Greetings,

Most common cause of this behavior.

 

IP address of printer is changing.  Printer does not have the IP your MAC thinks it has the last time it was used, or the name cannot be resolved using bonjour or WSD.

 

Assign a static IP to the printer.  Two ways to do this.

 

Printer;

Assign an IP, subnet mask and gateway.    Result, printer always has the same IP (devices can always find it at this destination)  Doesn't matter if you use it once a day, week, year, etc.  Always gets the same IP. 

 

https://oip.manual.canon/USRMA-3547-zz-SSM-740-enUS/contents/devu-setup-nw-ip-ipv4.html?search=tcp 

 

or 

 

Router:

Reserver IP Address based on printer's wireless adapters MAC address.  Result (Same) printer always has the same IP (devices can always find it at this destination) 

 

You'll need to consult your routers documentation.

 

This only has to be done once.

 

 

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

Rick,

 

Thank you so much for your reply and helpful instructions.   

 

I successfully assigned a static IP to the printer via the printer and I was able to print and scan.

 

Many thanks, 

 

Kathy

 

ps.   The test will be if I can print in another two weeks!

Hi Kathy,

I'm sure you'll be fine.

 

Good work!.  

~Rick
Bay Area - CA
~6D2(v1.1.1) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 3080Ti FTW3 Ultra ~ImageClass MF644Cdw ~Pixel6 ~R5C On Order

Hi Rick,

 

My printer worked just fine until but now it is not.  The message in the Printer Que is Printing - Looking for printer but it can't seem to be found.

 

Is this the same issue or do I have another problem.

 

Kathy

i'm struggeling with this problem too.  set a static IP and still can't find or connect

Hector
Product Expert
Product Expert

Hello Kep,

 

Communication issues from a Mac are usually caused by a network/address issue or by the drivers that are being used when printing. If you have already set a static address for the printer and are still having issues, you can remove the printer and add it again to make sure the Mac is using the correct drivers.

 

Click on the apple in the upper left hand corner of the screen and then click on system preferences. Once in system preferences click on Printers and Scanners. In printers and scanners, you can click the - at the bottom of the list to remove any connections for the Canon printer. Once it is gone, you can click the + to pull up the add printer window. You can select the printer and before clicking add, make sure the name of the printer appears in the USE box near the add button. If it is set to airprint or secure airprint, the Mac is not using the correct drivers.

 

If you do not have an option for the printer in the USE box, you can download and install the UFR printer driver using the link HERE.

Inkdust
Apprentice
My wife has this problem on her MacBook as well. I deleted the printer from her computer, then added it back. Other times I have to restart her computer for it to print. It's a hassle.
Announcements