cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MF733CDW doing strange things

rbaroncpd
Contributor

Hi all,

 

I am having trouble with my Canon Laser MF733CDW printer. For some reason it is changing IT'S own ip address several times during the day. It will go from 192.168.1.7 to 192.168.1.29 (last numbers vary) for no apparent reason. When it changes, it beeps a few times to let me know. Sometimes it beeps and I look and it is the same ip as the last time it beeped.

 

This bothers me because if I try to print something and it is in the "letting me know the ip changed" mode, I get a printer error.

 

Does anyone know why this is happening?

 

Thanks in advance,

 

Rich

 

PS: Is there a way to permanently assign an ip address to the printer?

1 ACCEPTED SOLUTION

shadowsports
Legend
Legend

Greetings,

This is the DHCP function on your network.  This is not a fault of the printer, but instead a result of your network configuration.  

 

How to resolve:

 

Assign the printer a static or reserved IP address.  Probably easiest to do this on your router.  This is a one time set up and will ensure the printer always gets the same IP address regardless of when it was last used, powered on/off, went to sleep, etc.

 

If you tell us the brand and model of your router, maybe I can point you to documentation or help on how to do this.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

View solution in original post

9 REPLIES 9

shadowsports
Legend
Legend

Greetings,

This is the DHCP function on your network.  This is not a fault of the printer, but instead a result of your network configuration.  

 

How to resolve:

 

Assign the printer a static or reserved IP address.  Probably easiest to do this on your router.  This is a one time set up and will ensure the printer always gets the same IP address regardless of when it was last used, powered on/off, went to sleep, etc.

 

If you tell us the brand and model of your router, maybe I can point you to documentation or help on how to do this.

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks for responding.

 

I have an Xfinity modem/router. With that I have connected a router caled ORBI. It has a base station plugged into the Xfinity modem/router and two additional satalite units around the house.

 

I hope this helps you to help me.

 

Thanks in advance..... Rich

HI Rich,

This is actually very helpful.

 

xFinity and Netgear.  

 

First thing to do.  You need to put your xfinity device into Bridge or Pass-Through mode.  You should be able to do this by connecting directly to the device and logging in. Typically there is a button in the device's web interface that is clearly marked.  The device will restart once this is done. 

 

Next, reset your Netgear Orbi and perform set up again.

 

Why this is important.  Both the xFinity router and Orbi products are designed to provide NAT and DHCP.  NAT is the firewall of the device that shields and protects devices on your home network from the outside.  DHCP is a protocol that manages the IP addresses which are assigned to computers and devices on your network.  Only one device can perform these services on your network.

 

Bridge or Pass-Through is exactly what is sounds like.  It basically disables the filterting and IP mangement and passes a clean internet signal from the xFinity device straight to your Orbi.  The Obri has some additional configuratin options as well. One of which is called AP (Access Point) mode.  This would be used if you wanted the xFinity device to act as the firewall and DHCP server on your network.  But again, it has to be one or the other.  The Orbi will do a great job.  

 

If both devices are left in their default configuration, something called Double NAT occurs.  This causes issues with communications and can actually keep devices from working correctly.  This will help explain it.

 

What is Double NAT? | Answer | NETGEAR Support

 

Don't worry, these changes are not that difficult to do and you'll get your network working correctly. 

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

With all due respect and thanks for responding but it sounds a little bit above my head.

 

It was working fine for years and then all of a sudden it started to change it's IP address.

 

I'll try and figure something out.......

 

Again, thanks much

I am having the same issue, using a Netgear N600 router DGND3700v2.  Any advice for me to assign a static IP address?  Thanks!

JudyJames
Contributor

Never mind, when all else fails, read the manual.  🙂  I was able to assign a static IP address by going to the MF733cdw manual, and found the directions to set it from the printer's control panel.  Hopefully this will stop the incessant beeping and messages.

shadowsports
Legend
Legend

Greetings,

The process for setting or reserving a static IP for a device on your network is not difficult, as @JudyJames figured out.  Quick 5 min read was all it took.  Good work.

I would typically recommend making this setting on the router, since it ultimately decides DHCP (IP assignments).  When done, it will never hand out the IP address you have reserved to another device on the network, even if that device is turned off, goes to sleep or is not used for an extended period of time.

The ISP's hardware does not come pre-configured for use with another router, mesh system or extender.  They will almost always conflict with each other until one or the other is told what not to do.  This type of configuration only needs to be done once as is "set and forget".  Done properly, no constant management is required.  IP's don't change and connectivity is maintained.

@JudyJames.   ( I see your device is all in one)

See this, Page 52

N600 Wireless Dual Band Gigabit ADSL2+ Modem Router DGND3700v2 User Manual (netgear.com)

This is where you will reserve the IP for the printer on your Netgear Product:

shadowsports_0-1653143733416.png

When a device is already connected to the router, pressing the Add button automatically does the job for you.  You can leave the assignment on the printer as well.  They won't conflict.

@rbaroncpd, If you are still watching this thread.  Your Orbi (also a Netgear product) has a identical set up.

 

  

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Thanks, Shadowsports!  I was able to make the assignment through the router, but pressing the Add button did not do the add automatically.  I had to do it manually by following the manual to copy the MAC address, etc.  Not hard, but a little scary for an old lady.  🙂

Anyway, I appreciate your help!  Thanks again.

Greetings,

Great to hear.  Best of luck with your printer.

 

~Rick
Bay Area - CA


~R5 C (1.0.7.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Avatar
click here to view the gallery
Announcements