cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon MF652CW Won't wake from sleep when sending print job over wifi

superiordwb
Apprentice

Everything had been working fine up until a week ago (bought it in Sept.). Now it won't wake up from sleep when I send a print job to it over WiFi. I'm now having to go over and hit the little moon icon to wake it up. I've updated the firmware, done a factory reset to it, and reserved it's address in my router but none of this has worked. Unless someone here can help me fix this, my next repair is going to be with a sledge hammer. I've also looked for a way to turn off it's ability to go to sleep but can't find it in the settings. The "Time to Sleep" setting is 1-60 but no option to just tell it to stay awake as far as I can tell. Any help would be appreciated.

6 REPLIES 6

TokyoTony
Apprentice

I just got the same printer yesterday. When it goes to Sleep, I have to manually push the button to have it wake. But, I did go to the Canon site to download the drivers. It works now but wow does it take a long time to wake up not doing so manually.

The other thing I still can't do is print from my phone when it is sleeping. I have to still manually wake up the printer.

 

shadowsports
Legend
Legend

Greetings Tony ,

I have some suggestions for you.  In the future, it's helpful if you start your own thread so that your issue can receive the support and visibility It deserves.  It also makes it easier for others searching for solutions to find answers more quickly.  Please consider this moving forward. 

Please take a look at your wireless router and assign a static IP for the printer.  Once assigned, restart the printer and confirm the assigned IP is correct.  You can do this by logging into the printer's web server, open a browser, put in the IP address you assigned, or by opening a command prompt and attempting to ping the printer's IP address you gave it.  Now retest and see if printing from another device on the network, computer or mobile device wakes the printer.  

Optional step:

After the above is completed, If the behavior does not improve, I might also recommend that you remove and re-add the printer to the computer(s) you're using it with as an IP printer.  

If you need help with this, please start a new topic and we can discuss further.  

First step > assigning a static IP to the device 😀

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Since he and I are having the same problem, it makes perfect sense that he reply to this thread. If he had started his own thread I would not have seen your solution to the issue. But I had already tried what you suggested without fixing the problem. My "not waking from sleep" problem happened suddenly after working as it should for 2 months. I've read on other forums that this is not an isolated incident. Nothing had been changed up to that point. I tried to box it up and return it but it was past their return window. So since nobody had responded to my thread with a solution, my fix was to buy a HP laser printer. It's been working like it's suppose to.

shadowsports
Legend
Legend

Greetings,

It might make sense if he were using the same operating system, same connection method and had a identical environment to yours, but chances are he doesn't so it's easier for those trying to help and for those looking for solutions if things are not co-mingled as the solution that works for you, might not be the right solution for another user's issue or environment.  

Issues like this can be related to the firmware on the device, a power management setting, or in the case of a networked device, the router or wireless. Consumer grade networking products and ISP issued devices are not typically the most robust.  They are often lower quality intended for mass production and distribution, not for reliability.  They are rarely updated once they get installed at your house and are often behind in features.  

I'm glad you have a solution, but his issue might need more investigation and troubleshooting.  It's helpful if this information is maintained separately.  🙂

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

I think I found the solution and it is printer related, nothing to do with the OS, etc. (Rick - Are you an admin for these boards? If not, thanks for the suggestion on the static IP but no thanks on how to post.)

On the printer itself: Menu-> Network Settings -Wireless LAN setting >Power Save Mode - Switched from ON to OFF

superiordwb: Maybe that setting got changed with a recent firmware update or something?? Anyway, that is working for me.

 

 

shadowsports
Legend
Legend

Greetings Tony,

Very glad I could help. I am not a Canon employee.  Just a fellow user like yourself.  

Since you are not the threads starter, it's not possible for you to mark your problem as solved.  This is another reason for starting your own topic.  I hope you understand. Please enjoy the printer.

Thanks,

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Announcements