Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎03-05-2018

Can not Scan with MF216n



I am using Windows 10, an Acer computer, and an ImageClass MF216n All in one Printer.  I am NOT directly connected to the printer (using wifi, direct connection is NOT the issue).


I can not Scan.  I have in the past off of my computer, but when I go to scan, i get an error message on the computer "Problem Scanning, Please try again".


I can click the preview button, and it scans the preview no problem.  The moment I hit Scan, I get this error message.


I can print to the printer no problem, and can see a preview of the scan (as stated above) but I can not perminant scan.


I have tried to look online, and there is little to no troubleshooting for this problem.



Can someone please help?  Thanks.

New Contributor
Posts: 2
Registered: ‎03-05-2018

Re: Can not Scan with MF216n

Also like to note:


i have tried using both the scanner flatbed and the feeder.  Neither is working (error message on both)

Product Expert
Posts: 130
Registered: ‎03-01-2017

Re: Can not Scan with MF216n

Hello luke1234,


I understand an error occurs when you attempt to scan with your imageCLASS MF216n.  To ensure we are on the same page, and resolve your issue with scanning, I suggest you uninstall the current drivers then download and install the Windows 10 drivers and Patch for Network Scan, USB Scan from our web site using the steps at this LINK.


If you need immediate assistance and you're in the USA, please click for our US-based support. If you're outside of the US, please click for support options.


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement