Showing results for 
Show  only  | Search instead for 
Did you mean: 

When will Canon drivers be updated for Mac Big Sur operating system?


The current drivers for Canon printers on Apple produts have never worked with the beta of the Big Sur operating system. (they only print table outlines but no text).  Feedback to Apple acknowledges that many people have reported this but the reply is the "OS is operating as currently designed", meaning Apple feels its Canon's problem.


Once the OS is public, how long will it be until Canon releases updated drivers? Anyone have any insight, experience, or notion of when (or if) they will do so?



I can't believe this, I have had a new MF644cdw for 3 months, updated to Big Sur, and now I can't print! What do you say Canon, " tough luck" or ?

Mee Too

I found the new Big Sur driver for the LBP6230 and I successfully installed version 1.5.7 on my computer, but now when I add the printer, it refernces the old driver version 1.5.4.  Any advice?

Nevermind.  It works.  Apparently there is a glitch that causes it to show the old version even though the new one is installed.



I do have an ImageClass MF726CDW.

I can only print using AirPrint to print using macOS Big Sur.


But I cannot find the scanner. 


The MF toolbox cannot find the scanner from the network.


It works fine in macOS catalina. 


What do I need to do to make it work using macOS Big Sur?


Also, how to update the latest firmware for MF726CDW in macOS Big Sur?


Many thanks!



I have two Canon printers, both obsolete: ImageClass D480 and ImageClass MF8380cdw.  When I installed Big Sur, there were no drivers for either one.  Then the printer driver came out for the 8380, followed a couple of days later by the one for the 480; the printing now works.   But none of the fax or scanner drivers would even install.  Today I found new drivers for these and they installed but don't work.  Be sure your drivers have 12/2020 dates or they won't do anything.  Like you, I cannot find the scanner for the 8380 and the 480 doesn't even recognize the scanner function.  I will keep checking to see if there are new drivers released that might work.


All the drivers on the Apple support site are way too old.  And Apple should have warned us that Big Sur was the operating system architecture that would blow up printing.  They warned us it was coming but never said it was here.

Like a cruel joke, I had one day of printing, even duplex printing and today -- nothing. Reset the printers, rebooted the computer. It was pathetic. You are right about the 12/20 drivers. This is infuriating. 

I just tried something someone else suggested.  I have installed all the new drivers for both the D480 and the MF8380cdw.  Printing works but not scanning.  I turned off my iMAC and my printers and started them again.  Now the scanning function (with the new driver) for the 8380 works but not for the 480.  But this was how it was prior to Big Sur.

I'm not sure why Canon has not posed this as a temporary solution - use the "Canon UFR II/UFRII LT/LIPSLX Printer Driver & Utilities for Mac Version 10.19.7" This works on a MacBook pro with OSX 11.1 While the "Ultra Fast Rendering" driver has a disclaimer that it cannot print in high reolution, it does seem to work well. A description comparing URF II & PCL drivers can be found here:

click here to view the gallery