Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5 Wi-Fi Connectivity Blocked by EOS Webcam Utility


Great Day! I hope you are doing well. I've previously posted about this issue and am seeking further assistance. I use the Canon Wi-Fi Utility to remote shoot regularly. Here's a concise description of the problem:

**Problem Description:**

1. I typically enable the camera's Wi-Fi and connect it to my laptop, experiencing no issues with wireless or wired connections during photo shoots.

2. However, as soon as I install EOS Webcam Utility Pro (version 2.0), the camera no longer connects to the EOS Utility wirelessly. It only connects when hardwired.

3. Interestingly, the hardwired connection works when using my Canon EOS R5 as a webcam via Zoom, as intended.

4. The problem arises when I attempt to use the camera's Wi-Fi for remote shooting at photoshoots.

**Steps to Reproduce:**

I have tested this on two different computers, both running Windows. Here are the steps to reproduce the issue:

1. Ensure both EOS Utility and EOS Webcam Utility Pro are installed.

2. Attempt to connect the camera wirelessly via its Wi-Fi or your local Wi-Fi network to EOS Utility.

3. Observe that the camera does not connect wirelessly to the computer while both software are installed.

4. Uninstall the EOS Webcam Utility Pro, then reboot your computer.

5. Try connecting the camera wirelessly again. It should connect as expected without the webcam software, but the webcam functionality will be lost.

**Additional Notes:**

- I am not trying to use both software simultaneously.

- I have verified this issue on both my Windows laptop and desktop computers.

**Request for Assistance:**

I am looking for a solution to this problem and would appreciate any guidance or troubleshooting steps. I would also like to know if others have encountered this issue and if it can be recreated on different devices. Sure I can uninstall and reinstall when needed but I'm sure that's not the intended use case. 

Thank you for your attention to this matter.


@coreyreesephoto wrote:

Hello that doesn't work either, I found these services "ewcservice.exe and ewcpairingservice.exe that's connected to the web camera utility  but that still doesn't solve the issue. Camera reads connection target not found still. 

Did you stop them, disable them, and then rebooted the PC?

"The right mouse button is your friend."

View solution in original post


I noticed that, too.  That’s why I suggested stopping the WebCam services.  One might need to reboot after disabling them.

"The right mouse button is your friend."

Hello thanks,  I didn't realize one of the features with the paid web cam is to connect wireless so canon was indeed blocking the eos utility wifi connection when both are installed and running in the background. I went back to Waddizzle  suggestion and that worked.  Stopping services ewcservice.exe, ewcpairingservice.exe then making sure they are both set to manual start vs automatic and reboot the pc. Eos Utility is back connecting while the web cam software is not running in the background. 

Not applicable

It looks like you can't have both utilities installed on the same computer and both trying to connect to a camera via a Wi-Fi connection. You could call Canon at 1-800-OK-CANON (800-652-2666) and see if they have any suggestions. 

Another option is if practical, try connecting the camera with a USB cable when using the EOS Utility.