Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam will not install EWCService.exe failed to start. Verify.....sufficient privileges


Windows 10, fully updated as of 2/10/23.  

I borrowed some text from another thread but it describes the problem in detail.. 

"It flat out refuses to install. I go through all the install process, it unpacks, goes through install progress bar comes close to complete, it hangs for several minutes and then pops up with

EOS Webcam Utility

! Service EWCService' (EWCService.EXE) failed to start. Verify

That you have sufficient privileges to start system services.


Try retry all day long and it just repeats only option is to cancel"  .......which uninstalls the package.

I am administrator and right clicking and running the install as an administrator does nothing.


I have rebooted, updated the machine to the latest version available and installed GPEDIT.MSC and set privileges in it according to a web article.  Still does this and it will not install. 

The log that is generated is useless.  The developer created an exception routine but didn't put anything in the log to say why the exception occurred.   




So, with no changes made by me to the machine or operating system, today I downloaded the latest version of the webcam utility and ran it full expecting it to fail during installation.  Much to my surprise it has successfully installed.  Now I need to reload software to see if it works!  Not enough time today but will let everyone know if I get it to work.  At least one step in the right direction!!!!!

Was never able to get a picture or video...but no error messages.  The camera was loading as a portable device using MTP.  However, under Device Manage....cameras...the utility was not showing as it does on my Win 11 machine.  So deleted the install and tried again.  This time got the original error message about privileges so rather than finishing the install I hard shut-off the machine to get out of the install program without it deleting the install.  Rebooted and now I have the camera as a portable device AND under device manager..cameras...I see the utility.  Fired up Windows "Camera" and can select the EOS device and it bringss up the Utility opening screen but I do not get any video or picture feed.  Most likely something at the end of the install process ties the MTP to the utility.    



Unfortunately when I plug it in via USB nothing pops up like when I connected my cell or a portable HDD .. and I still get the EWCService error message and when I got to the setting to manually start the EWCService I get error code 1053

While the error message shows a 1053 as a timeout it is not.  I set the timeout manually and still get the error.  Maybe someone who developed the software will take pity on us.  There are a number of things that can generate the 1053, privileges are only one.  I have ruled out privileges and timing but other dependencies can generate the error.  Without detailed knowledge of the install process I can do no more. C'est la vie!

After reading all the comments on this thread, and jumping through the same hoops, your latest problem struck me that I had seen this before. Below is a link to a topic on YouTube about the camera not be recognized by the computer. Here it is:

It describes this very problem.

In a nutshell, what is going on is everytime you boot your computer you have to go in and turn off the EOS Utility, not the EOS WebCam Utility. Then the camera is recogInized.

This must be done everytime you boot your computer if you are going to use your Canon camera as a Webcam.

This whole process has been a, "pat-your-head" and "rub-your-tummy" at the same time experience.


The computer recognizes the camera because I am able to move photos and Vito’s to and from the computer but I’m not able to install and run the app that is where the problem begins is during the app install process 


I don't use this particular program, but I have ran into the "insufficient privilege's" error before.

As the admin, this was puzzling. However I found a tip somewhere that worked for me. I made a new user and gave that user full rights. Shut down and restarted my system, then logged on as the new user and installed the s/w without issues (no error message). I then logged out of that user and logged in as myself and the s/w worked as expected. Hopefully, this will work for others... No guarantees, but worth a shot.


I’ll give this a try thank you 

click here to view the gallery