Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility not showing camera feed - EOS M50 Mark II


I just moved to a different computer (same cables) and on this computer the EOS Webcam Utility only shows the black screen with "EOS Webcam Utility"

I have triple checked that the other EOS Utility is not running, the camera is in airplane mode, I have checked the USB cable and tried another USB cable. I have the camera in video mode now and still nothing.

OS: Windows 10

Camera: EOS M50 Mark II

Utility Version: 2.0.30



Which camera are you using? Which version of Windows are you using? Do you have the most up-to-date version of the EOS Webcam Utility Pro installed? 

Windows 10, EOS M50 Mark II, Version 2.0.30 of the utility


You have to make sure regular EOS Utility is not running, as well as the EOS Utility Launcher Service.  If you see a camera icon in the system tray near the clock, then right click on it and select EXIT.

You might want to try different USB ports.  The Canon apps do not seem to work when a passive USB hub is being used.  Many laptops and PCs use one internally.  In these cases, there is only one USB port that is connected directly to the motherboard.

"The right mouse button is your friend."

Like I said, the other EOS utility is not running and I have tried other USB cables including other ports.

Product Expert
Product Expert

Hi unknowjondoe,

Go ahead and turn off airplane mode and then make sure that Wi-Fi is also turned off. Then try additional tests.

If problems persist, please elaborate on what other accessories you have connected to the camera and the computer.

What program are you using for livestreaming? Have you tried other livestreaming options?

Are you able to download photos and videos to the computer when not using EOS Webcam Utility?

click here to view the gallery