Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility not connecting


I just purchased a Canon EOS Rebal T7 and all of the necessary cords to connect it as my webcam.  I downloaded the EOS Webcam Utility and installed it without problem, and it immediately popped up as an option in my webcam lists.  The problem is that when I go to use it as my device, it only shows a screen that says EOS Webcam Utility and a picture of a USB cable and a red X above it.  My camera is connected via USB through what I'm quite confident is the correct cable.  I have tried on both battery and plugged in with the adapter. I have tried all the things I have found on the internet so far (restarting my computer, restarting the camera, changing the memory card, checked that I'm in movie mode and not recording, turned off the auto-power off, turned off the camera wifi).  I'm out of ideas and I really want this to work (it's the whole reason I bought this camera).


Well nothing comes immediately to mind,other than making sure both your camera n the software you download are one of the listed cameras on canon's web cam utility page. Try different cables. Make sure you disable the wifi settings on your camera if it is equipped with wifi. You can fine the wifi setting on your canons camera set up menu. Make sure all your software and computers are up to date and or compatible. Ensure the lens cap is off and the camera is set to video mode.

Thanks, I'll try cables.  

You are a life saver. I bought two of these cameras for my home studio and took one back because I could not get it to connect as a web cam.

Thank you for the knowledge


So for my 5d MarkIV running Ventura 13.4.1 adding EOS Utility to open on login connecting the camera and turning it on. Then log out and log back in this worked for me. Good luck