Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility not connecting


I just purchased a Canon EOS Rebal T7 and all of the necessary cords to connect it as my webcam.  I downloaded the EOS Webcam Utility and installed it without problem, and it immediately popped up as an option in my webcam lists.  The problem is that when I go to use it as my device, it only shows a screen that says EOS Webcam Utility and a picture of a USB cable and a red X above it.  My camera is connected via USB through what I'm quite confident is the correct cable.  I have tried on both battery and plugged in with the adapter. I have tried all the things I have found on the internet so far (restarting my computer, restarting the camera, changing the memory card, checked that I'm in movie mode and not recording, turned off the auto-power off, turned off the camera wifi).  I'm out of ideas and I really want this to work (it's the whole reason I bought this camera).



I forgot to say: I'm on Windows 10

Well, it certainly sounds like you have checked all of the boxes.  I still do not know what the "Red X" may mean.  It either  means your device is not supported, or it thinks that a webcam is not connected.  


For the benefit of others who may see this thread in the future, here is the link to the EOS Rebel T7 Product Support Page. 


A good test of your setup is whether or not you can run the regular EOS Utlity to download files.  A better test is whether or not you can use the regular EOS Utility for Remote Shooting.    If this works, then we know your cable is good.  Besides, it seems like the Webcam Utility might need something that that the regular EOS Utility installs on the system.


If it does not work, the problem could be either your cable or the USB port on your computer.  Try all of the ports on your computer. Some users hve reported that USB ports on the front of their tower PCs do not work, but the main port on the rear of the PC would workl. This caused by some USB ports are actually coming off of an internal USB port expander.  Canon cameras and USB port expanders do not seem to like one another.


Which brings us to your atual PC.  So, what make and model of computer are you using.  Just running Windows 10 only partailly meets the requirements.  There are hardware requirements, too, which have to be met.  They might look like this.




An Intel chipset seems to be preferred over an AMD chipset.  There's someting about the AMD USB ports that Canon cameras do not like.  No idea what it might be, but I have a few good guesses.


Finally, you need to make sure tha tthe EOS Utlity Launcher Service is not running when you try to use the Webcam Driver. There is an icon in the System Tray that shows you when it is running.  If it is running, then the Webcam driver seems like itis blocked from accessing the camera by the EOS Utility Launcher Service.

"The right mouse button is your friend."



If this is the image you were getting like I was make sure that your cameras Wi-Fi connection is disabled as having the Wi-Fi function on will disable the cameras HDMI, USB ports. Which will prohibit the camera from connecting to your computer. It took me hours before I read the prompt it gave me when I was trying to get my camera to connect to Wi-Fi on my computer. When I disabled the Wi-Fi feature the camera finally connected.

That is if your camera is equipped with Wi-Fi. Mine is a EOS T7 that has the Wi-Fi Feature which will allow you to connect to your phone. Its a pretty cool feature but the draw back is that it disables your display ports on the side of the camera.

I had the same problem.


I tried another mini-usb cable, and it worked.


Note that when it did start to work, the canon helper program started, and the error message in OBS changed display, but OBS wasn't fixed immediately.  However, once I closed canon's problem, the image in OBS adjusted.

I can now use the camera as a webcam from OBS directly connecting the camera to my computer via mini-usb.

Thank you! This saved me hours on a few hours of time over a long period of time trying to install/uninstall, try again, even tried a new usb cable. But after turning off wi-fi it started working within seconds! Thanks!

OMG I spent hours and even canceled my live video because it wouldn't connect, found this tidbit and it works now. I thought there was a shortage in the port because I've had to send my t6i in twice for repair now. thank you!


All I get is a grey screen.   I don't even see anything like this that says EOS webcam utility.   Any ideas?