Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility is not functioning with my t6i



I have a rebel t6i that I cannot for the life of me get to work as a webcam on the EOS webcam app. I have my rebel connected via usb, I have wifi disabled on the camera, It is set to movie mode and the LCD screen is displaying that it is connected to the computer. The EOS utlity app is closed and webcam utility is running. I know my cable is fine because I can remote shoot on the Utilities app. However, after I close it and launch the webcam app, I just get a blank screen that just says "EOS Webcam utilities" in it.


Does anyone have any idea whats going on with it? Ive uninstalled my drivers and tried every solution on every forum and nothing seems to help.



What Operating System is your computer running?

If you have a Windows OS, then you need to disable the EOS Utility Launcher Service.  There should a little camera icon in the System Tray in the lower right corner.  Right-click on it and select “Exit”.

"The right mouse button is your friend."

I’m running windows 10. I tried ensuring that eos utility was fully closed. We also uninstalled utility and kept webcam installed and neither of those worked. 


I too am having same issue on my windows 10 PC with and chipset.. There is no other program running that would or could use the t6i. at least none that I can see within task bar or task manager. All I get is the eos webcam utility sign, the tool doesn't open or run and doesn't seem to see or recognize the camera. Ive uninstalled, rebooted and installed all items a few times and still nothing. any other tips or help to get this running? I even updated the t61 firmware to be up to date.

Product Expert
Product Expert

We recently released an updated version of EOS Webcam Utility, so I would recommend getting it from the site below:

After loading the update, check to make sure that Wi-Fi is disabled on the camera. Then make sure that the camera is set to shoot movies, not stills.

If problems persist, try doing tests with different livestreaming platforms like OBS, Zoom, and Microsoft Teams to see if the issue is platform specific.