Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility doesn't work with macOS Ventura


Hi there,

I've recently upgraded to macOS 13 (Ventura) and EOS Webcam Utility doesn't work anymore. I tried both amd64 (EOS Webcam Utility 1.0) and arm64 (EOS Webcam Utility 1.1) versions, but none of them work properly.

EOS Webcam Utility 1.0 freezes, and EOS Webcam Utility 1.1 only works once after a system restart when camera is turned on and off a couple of times, but then system loses the connection with the device.

Please publish a fix of the software as soon as possible for your customers like me who are depending on the camera for their day to day work.



I have Canon 90D and I had the same problem that you described, 
I saw solution from youtube and is fixed my problem.
here is the step you should to do hope it will work for you.

1. Delete the EOS Utility & Webcam Utility from your MacBook, also the plugs. -> here is link how to do that. Click Here.

2. Restart the mac. 

3. Go to Canon US download site.

4. Select you camera and after that SELECT version macOS11.

5. Scroll a little bit down and you find EOS Utility 3.16.1 for macOS download it.

6. Install, then go again to Canon US download site.

7. Select you camera and after that SELECT version macOS12.

8. Scroll a little bit down and you find EOS Webcam Utility Pro for macOS download it.

9. install, that's it.

hope it will work for you.

rjv - did you mean uninstall the Webcam Utility or just the regular EOS utility?

i fixed the guide 🙂 

Perfect.  I feel like I had done a version of this before, but this time it worked.
I also installed the older version of the webcam utility instead of the 2.0 version - not sure if that mattered or not, but the camera does work as a webcam now.

This is unfortunately not a solution. We're still waiting for a new release of EOS Webcam Utility which needs to work with macOS 13 (Ventura).

i also have macOS 13 (Ventura) . you just need to dropdown the version of EOS Webcam Utility and EOS Utility


This is still not working for me on my Macbook M1 on Ventura 13.1. It still comes up saying The Installation Has Failed. I have deleted the plug ins, uninstalled the EOS Utility, installed the EOS Utility 3.16.1 explained above. Still does not install. It should be noted that every time it is said to "redownload the Webcam Utility" from Canon's site, it is the same file from Oct 31,2022 meaning it still has the same issues. We dont need 'work arounds' CANON NEEDS TO UPDATE THIS UTILITY, especially if they are charging to use premium features under a subscription. This is frustrating, and THIS HAS NOT BEEN SOLVED!

Hi there.

This thread is about the EOS Webcam Utility, which was updated to version 2.0 on 11/9/22. If you don't see the updated software in your available downloads, simply change the dropdown to macOS 12 and you'll see version 2.

Please see for more information on the EOS Webcam Utility. If you find you need one-on-one help, give our team a call at 800-OK-CANON (800-652-2666) and they'll walk you through the installation. 

Are there any information about the release date of EOS Webcam Utility version that is compliant with macOS 13 (Ventura)?


Same here.

Thought that version 2 would solve it, but it didn't change anything.

click here to view the gallery