cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility Pro - Rebel T7 no connection

bfsmith
Apprentice

I've read over a number of posts like this, cannot figure out why the camera will not show up under the source, video capture menu except the built-in FaceTime camera in this MacBook Pro.  Can anyone suggest anything?  Some strange nuance on the camera perhaps?  Here is my setup:

1.  Using a MacBook Pro M2 with Sonoma 14.2.1

2.  Camera is an EOS Rebel T7 with firmware updated to latest v1.2.1

3.  EOS Utility 3 installed and connects OK - v3.18.0.1

4.  Latest Webcam Utility Pro activated with paid subscription - v2.1.18.702

5.  If I open ImageCapture on the Mac, it will connect to the camera fine and show all the images written to the card.

6.  I have disabled the Wifi/NFC option on the camera so the USB interface will work.

7.  Using EOS Utility 3 I'm able to remote control the camera, so that's two apps that have proven they can communicate with the camera fine, nothing wrong with the USB cable.

8.  I'm using the EOS Webcam hardware kit, that came with a dummy battery, AC adapter, and the USB cable.

 

5 REPLIES 5

NatalyaP
Product Expert
Product Expert

Greetings bfsmith,

Let's check to make sure that any other software application that can communicate with the camera is closed completely. For example, you have listed that you have tested the camera with the EOS Utility application along with Image Capture. Please check to see if those may still be running in the background. Please close those applications and then test to see if the EOS Webcam Utility is able to display the camera. You may also restart your computer and open EOS Webcam Utility first right after macOS displays the desktop.

roguemonkee
Apprentice

I am having the same issue with the EOS Rebel T7. I have tried on Mac mini with Sonoma, Windows 10 Pro, Windows 11 Pro on both a desktop and a laptop with no success. All I get is the blank/black screen with the words "EOS Webcam Utility". I installed the Webcam Utility with the driver only. The camera is available in the device manager and settings application in either OS. The utility app shows that I am "streaming" but no video from the camera just the default placeholder text. I am using the Free version (no sub) and I would be interested in the Pro features if this Camera is supported. If it is not, just remove it from the supported devices list and be done with it and I can move on with another competitor.

Screenshots are from Lenovo Yoga 7i with Windows 11 Pro.

Screenshot 2024-05-19 115830.pngScreenshot 2024-05-19 115943.png

 

scorpiofr33
Contributor

having the same issues, any solution?

Nick2020
Product Expert
Product Expert

Check to make sure that your camera is set to shoot video, not stills. Then try recording clips to the card and then see if it makes a difference whether there is a card in the camera or not. 

You could also try using a variety of livestreaming platforms like OBS, YouTube Live, and Zoom to see if the issue is platform specific. 

GlenroseMedia
Contributor

Had similar issues, noticed that the disk activity light on my camera was almost solid lit when webcam utility was trying to access camera. I removed the memory card, and camera instantly appeared in the webcam utility, and streamed in OBS as expected.

Can’t explain why it worked, but it did.

JP

Avatar
click here to view the gallery
Announcements