Showing results for 
Show  only  | Search instead for 
Did you mean: 

EOS Webcam Utility + Apple Silicon / M1 Mac


EOS Webcam Utility doesn't work with apps like Google Chrome with M1 Macs, but it should be able to easily with some help from Canon.

I recently switched to an M1 powered Macbook Pro from an Intel one and noticed that after installing the utility, it didn't show up as an available camera. Doing some internet searching including on this forum I found the following advice:
1. Use OBS Studio as a virtual camera.
2. Use the x86 version of Google Chrome in Rosetta

Neither of these are a great option though as running OBS is purely band-aid and the x86 version of Chrome in Rosetta has a massive performance hit for me on my machine.

So I decided to do some debugging as to why it wasn't working. (Why does it work in OBS and perhaps some other places but not in Chrome) and it's actually really simple:

Error loading /Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility: dlopen(/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility, 0x0106): tried: '/Library/CoreMediaIO/Plug-Ins/DAL/EOSWebcamUtility.plugin/Contents/MacOS/EOSWebcamUtility' (mach-o file, but is an incompatible architecture (have (x86_64), need (arm64e)))

Chrome (and probably other apps) bail out when they try and grab the device because EWCService / the CoreMediaIO DAL plugin is compiled for x86 instead of ARM.

I don't have access to the source code (the community would help with these issues if you open-sourced it Canon btw 😉) which limits my ability to go further, but my strong theory is without much work if the existing EOS Webcam Utility for Mac was just compiled / available for ARM then it'd work with a bunch more apps. It could be as simple as changing the build target.

Is there a place we can write up tickets for the EOS Webcam Utility team?


EOS webcam utility was released in Asia for Mac silicon. I downloaded this update for my M1 Max and now EOS integration works fine. Nevermind the won't-solve post.

View solution in original post


Product Expert
Product Expert

Greetings optimal_flynn,

The EOS Webcam Utility does allow certain Canon cameras to function as a webcam with certain operating systems and computer processors. At this time, the EOS Webcam Utility is not available for computers running on Apple's M1 processor.

I'm sorry but customers are unable to provide tickets to our software engineering team and our software engineering team does not partner with customers with updating and developing Canon software.

In the meantime, I have submitted your feedback to our software engineers. Please note that decisions to update Canon software are made by our software engineers based on a number of factors. Consumer demand, technological limitations, and customer feedback are all taken in to consideration.

I've lost faith in Canon over this. Canon has had literally years to address this and has lost focus on their customers.

I'm not sure why this is marked as a solved when no solution has been provided yet for this issue. Please unresolve it until the issue is actually addressed.

EOS webcam utility was released in Asia for Mac silicon. I downloaded this update for my M1 Max and now EOS integration works fine. Nevermind the won't-solve post.

Wow, great, "Asian" webcam utility works perfectly fine on my M1 Mac Mini so far! 

This is not a fix. I still have to use a third party streaming app to connect camera operating programs like Zoom to the Asian EOS, I can’t open the Asian EOS as a stand-alone software, and my M50 freezes after a few seconds regardless of which programs I use.

that's another notch in the let your software engineers know M1 mac's need the integration. sooooo many people are switching to Silicon Macs.


Well, IMO, Canon has really dropped the ball on this.  Apple Silicon processors for Macs were announced in June 2020.  Apple made HDKs (hardware development kits) available so that companies could start updating their software before the first Apple Silicon Macs made it to the public (around Nov. 2020).

This is no different than the several transitions that happened beforehand.  On the Mac platform alone, this has been moving off of 68K processors to PowerPC, then from PowerPC to Intel, from 32-bit to 64-bit, and now Intel to Apple Silicon.   In all cases, Apple has provided software developers an easy mechasnism to create "Universal" binaries.  It's what I personally did for all these transitions.  i.e. a single app that ran natively on both 68K and PowerPC.  Single app running natively on both 32-bit and 64-bit, etc.

Apple has outlined that their transition to Apple Silicon would take two years.  As of now, there's only a single Mac that is still shipping with Intel processors; the Mac Pro.  All others Mac product lines are on the new processors.  To be fair though, Apple discontinued the iMac Pro.  So if they choose to re-introduce that, then there would be two Macs to update.


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

I agree they have dropped the ball. I purchased an M1 in 2021 and my canon cuts off when i used the virtual camera method. I don't feel like i should have to buy another camera but at this point I'm looking elsewhere or use my phone for live streaming.

click here to view the gallery