Showing results for 
Show  only  | Search instead for 
Did you mean: 

new computer - Windows 7 won't recognize my camera. Rebel T1i


I got a new HP computer with Windows Home Premium. My old Dell with Windows 7 worked great with my Rebel T1i and the Canon software that came with it. I was so spoiled! Now when I connect the camera and computer.. nothing happens. I have un-installed and re-installed the softeware ( EOS DIGITAL Solutions Disk 22.2) and downloaded upgrades. No change. I don't know where to go from here. I hope someone can help. Is my problem compatibilty, "settings" or has my computer been cmprimised by a virus. I sure hope someone out there can help me.


     Bewildered and bothered... bugshutter



I doubt it's a virus.  And I would guess that there shouldn't be compatibility issues with the T1i and Windows 7, the camera isn't that old.  Are you using Digital Photo Professional, EOS Utility, or something else?   I would recommend downloading the latest of version 3 of DPP and version 2 of EOS Utility just to be sure.


Are you using the same cord or just any old USB cord?  I have had problems with my computer not seeing my camera when using a USB cord without a ferrite bead (a cylinder at one end of the cord).


And, all that said, I wouldn't even bother with it recognizing my camera unless you're trying to tether.  If you're just trying to download your photos I'd take the SD card out of the camera and put it in the computer.  Get a card reader if you need to.

Thank you. I'll try downloading the more recent versions of DPP and EOS utility. My system worked perfectly on my old computer. I'm spoiled.

Thanks.. I'll try that.

Dear Skirball,



Dear Skirball,


    As it stands now, I can download my images from my computer via several steps. That gets tiresome. When I connect my camera and turn it on, EOS Utility does not come up. I tried going to "preferences" but the choice "Start EOS Utilities when camera is connected" is not active. What's wrong??/


      I want to follow up on your version 3 of DPP and version 2 of EOS Utility. I went to the Canon website and to mt surprise the Rebel T1i is NOT on the list. Could I do any harm by downloading based on the Rebel T1 cammera?


  Thanks again .... Diane

Hi bugshutter!


I usually don't step in, but you seem a little confused, so I thought I'd help out!


Check out the following link: Drivers and Software


Once you get there, the site should recognize your Operating System  and give you the options to download/update several pieces of software. The most current version of The EOS Utility for the Rebel T1i is EOS Utility 2.14.10b Updater for Windows, and the most current version of DPP is Digital Photo Professional 3.14.47 Updater for Windows


You shouldn't have to uninstall anything -- these are updates. If you have problems or get stuck, please don't hesitate to call or email our all-American technical support team at They're pretty awesome!


We hope this helps!


A couple things, one of my sons has a T1i and I know they connect it to their computer.  Windoze does not need any additional driver or software to see the Rebel T1i.  So, does the camera show up in My Computer?


Another, possibility, that I found out the hard way is Canon drops older camera's from the newer "updates".  Why, I have no idea?  This may be the cause if you d/l any updates.  I am not sure on the T1i.  Do you still have the original CD?  I would just use it.  But you must remove ALL the remanats of the previous instalation.  Every bit or you are wasting your time.


EOS 1DX and 1D Mk IV and several lenses!

So, I should delete my present versions of DPP and EOD utility before attempting to download newer versions?

"I should delete my present versions of DPP and EOD utility before attempting to download newer versions?"


Yes, by all means.  Use your original software.  Updating Windows will not help.  All the drivers you need are already there.


By uninstalling, I mean you MUST get rid of all traces of the present install.  If you leave any of it, it will still fail.

EOS 1DX and 1D Mk IV and several lenses!