Showing results for 
Search instead for 
Did you mean: 

my t4i will not read any SD cards


When I try to take a picture, it says: "Card cannot be accessed.  Reinsert/change card or format card with camera."


So, I try to format the cards, and it says "Cannot format.  Change card."


I have used both these cards before and never had a problem, this just happened all of the sudden.


I even tried re-formatting the cards on my computer, but no luck.


@Richard wrote:
Hi evanjamesmommy, I recommend contacting us for assistance. For contact options, please use this link:
Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I don't think I'd hold my breath waiting for "evanjamesmommy" to click the button. It's been more than two years since she posted to this thread.

Philadelphia, Pennsylvania USA

This seems to be a common problem with canon cameras. I have had my T4i for three years now and today is the first day it will no longer read memory cards. Have tried 3 different cards all have the same result they will not work in the camera.