cancel
Showing results for 
Search instead for 
Did you mean: 

autofocus not working properly with body

edmunds8119
Apprentice

Hello everyone, I am having trouble with the autofocus on my 100-400mm lens with the canon 7D body. I went to shoot the surf as I do every morning today and it wouldn't focus right on the surfer. First I thought the calibration or something was wrong or the AF has broken but I tried it on my friends 7D and it was right, quick and sharp like mine used to be. I do not understand our settings appear to be the same?!? Any ideas people, PLEASE! Thanks

3 REPLIES 3

cale_kat
Mentor

I was going to suggest that your settings might have moved. You say "appear to be the same" when mentioning the settings but that doesn't sound as certain as "are the same". What autofocus setting do you use?

amfoto1
Whiz

Try cleaning the contacts between body and lens. Use isopropyl alcohol and a clean rag to wipe them. Also check the corresponding "pins" in the camera, which are spring loaded and should give a little but pop right back into place under light pressure. Of course, be careful to keep off the lens optics and camera mirror when working around them.

 

You also might do a reset of the custom functions and factory reset of the camera, so see if you've overlooked something that's set incorrectly. You'll lose all your personal settings doing this, of course.

 

Finally, if neither of the above help, you might "reboot" the camera. To do that...

 

1. Turn the camera off.

2. Remove all the batteries, including the smaller date/time battery that's in a drawer on one side of the main battery compartment.

3. Turn the camera on.

4. press the shutter release button once. The shutter won't fire, but this should immediately drain any remaining power in the camera's circuitry, forcing it to do a complete reboot.

5. Turn the camera off, reinstall all the batteries, and then turn the camera back on.

6. Check the date/time... if it needs to be reset, you got a proper reboot. If not, repeat the process. If this still doesn't reboot the camera, repeat but instead of pressing the shutter release button let the camera sit for about an hour, to allow remaining power to drain off slowlly.

 

If you get a proper reboot and the camera still doesn't focus the lens properly, you might try reinstalling the firmware. Download a fresh copy from the Canon website and follow the instructions carefully.

 

If none of this works, and it's not guaranteed it will (but all are things you can easily try yourself and are free to do), I'm afraid you'll need to have the camera looked at.

 

Keep us posted.

 

***********
Alan Myers

San Jose, Calif., USA
"Walk softly and carry a big lens."
GEAR: 5DII, 7D(x2), 50D(x3), some other cameras, various lenses & accessories
FLICKR & PRINTROOM 

ebiggs1
Legend

"... I tried it on my friends 7D and it was right, quick and sharp like mine used to be."

 

This tells you that it is something in your camera.  A cleaning of the contacts on the 'camera' is warranted.  But not the lens.

Also, I prefer denatured alcohol as a cleaning agent.

A reset of the cmaera is also a good idea.

Firmware malfunction is unlikely.  A better idea would be to try other lenses.  Do they work OK on your body?  Or, is it just the 100-400mm?

 

Surfing = salt and spray! Smiley Frustrated

EB
EOS 1DX and 1D Mk IV and several lenses!
Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM