cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Thoughts on focus problem

coachboz68
Enthusiast

7D + 70-200L.  But I don't think it's the body or lens problem, per se. 

 

My daughter was out shooting today.  She's learning.  Pretty new still.  Came back and 80% of her pics were not just out of focus, but there was no focus lock achieved (could tell by turning on the AF Point Display in camera playback).  She's using shutter-button focus.  Mind you, this wasn't that it was back- or front-focused... the whole picture was out of foucs with no focus-point lock achieved.  She was in center-mass focus point grid (next-to-the-last of the focus point options) and from the look of her pictures, even in AI Servo mode, it should have acquired *something* in the image.  she was plenty far back, so I don't think it was a focusing distance problem. 

 

I tested it tonight when she got home and everything was working fine.  Even in AI Servo mode. 

 

My theory is that she did not put the lens on properly (she still struggles getting it on correctly) and something wasn't communicaing between the camera and the lens.  But that's just a theory as I cannot recreate it.  Could that have happend?  Or is the lens either on properly or not at all?  (a very few of the pics did show focus lock)

 

If anyone else has any speculations, I'm open to it.  She's a novice, so anything is possible.  🙂 

 

Billy

14 REPLIES 14

Posted on You Tube March 24th 2015  type in Canon 7d soft focus easy fix... you might learn something....


@ABBOTALE wrote:

this does actualy work so please if you dont have 7d mk1 dont make out people to be idiots!!!! Ohand by the way most if not of you so called SOLUTIONS havent Worked.........


Hi.  It's helpful if you Quote the text/person to whom you are responding.  Given I started the thread, I will assume you directed your comment at me, and yet I do not believe I said anything that would be insulting or condescending to you.  My apologies if I did, but I'm not sure what that would have been.  

 

Next, I was not looking for a "solution" because, as I said at the start, the problem is not reproduceable.  Therefore, I was trying to go through a thought experiment of what *might* have happened.  I am appreciative of all who replied with ideas, including yours, to which I responded appropriately (or so it seemed to me).  

TCampbell
Elite
Elite

For clarity... is this an original 7D or is the 7D II?  I ask because there are significant differences in the focus system.

 

When a camera is in "One Shot" AF mode *and* a lens is attached and switched to "AF" (auto-focus enabled) then the camera uses "Focus Priority" ... meaning it wont let you shoot unless it can confirm it has managed to focus on at least ONE AF point. But that's really just a temporary gate because once the camera locks focus, it stops focusing... any photographer movement AFTER the focus is achieved will not update focus  (so if she focuses & moves... then it would explain the problem.)

 

But if the lens is in "MF" mode or if the camera thinks no lens is attached (becuase it wasn't rotated until the locking pin engaged) then that could also explain the lack of focus.

 

 

If, instead, the camera is in "AI Servo" mode, then the camera will focus cotinuously... with the caveat that it also now uses "Release Priority".  So a quick mash of the shutter button (without pausing at the half-press point to make sure it really does focus on something) would causes it to release the shutter immedaitely... even if it didn't have adequate time to focus.

 

So that's another possibility.

 

 

You'll likely need to go out with her and observe how she shoots... pick a few subjects at different focus distances and have her move from object to object so that the camera is forced to re-focus.

 

 

 

Depending on the camaera model (7D vs. 7D II) there are differences in how the focus system works.  It *sounds* like you're using one of the "zone" focus modes and you've picked the zone in the center.  Whenever any Canon model (that I know of) is allowed the use of more than one focus point, it will tend to lock focus on the "closest" thing available (the camera assumes your intended subject of interest is the one closest to the camera) and to over-ride you'd need to switch to a focus mode that doesn't let the camera use multiple points (so now it has no choice but to focus on the thing you picked.)

 

 

Tim Campbell
5D III, 5D IV, 60Da

ABBOTALE
Contributor

If it's the 7D MK1 there's a simple solution i had the same problem..1. In menu settings go to the setting second from last (pic of a  camera ) next to a white star green backgrounds Then scroll down to AUTOFOCUS/DRIVE....MICROADJUSTMENT..THEN PRESS ... DISABLE.. OK SO FAR..

2. In the battery compartment there is a second battery it's on the flat side of the compartment take it leave it out for 10 mins then put it back in your problems will be solved.

3 just re set time/date

It is a Mark I.  Funny you bring this up.  YEARS ago (like 5?) I was having what I thought were some microadjustment problems and I did this exact procedure.  Surely no harm in doing it again!  However, in that case, the symptoms were quite different.  My daughter is a complete novice (20yo, btw, so not "a kid"... though it seems that way to me still! 🙂  but I have been using Canon gear for about 12 years as an advanced hobbyist.  So while nowhere near the levels on this forum, I'm usually able to get somewhere in the neighborhood of a problem.  In this case, I think she did something really "wrong" during the shoot.  Behavior is too anomalous to suggest a systemic problem in the gear.  But, that's why I said this is a thought experiment!  The world may never know... 🙂    But I love hearing the suggestions!  Always learning... 

Avatar
click here to view the gallery
Announcements