cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Stripes, Banding and Purple or Green Blocking on Photos - Happens in Heat

jmquig
Contributor

I'm an amateur photographer and I was using my Canon EOS Rebel T3 at Disney World this past week.  The majority of my photos turned out well, but later in the day around 4 pm I started seeing problems on the pictures. This was visible on the LCD viewfinder, and apparent on the photo downloads as well.

 

IMG_6202.JPGIMG_6247.JPG

 

The issues included stripes on the photographs, banding on some pictures, and purple or green color blocking on the pictures.  I am so bummed because all the pictures from this time frame are ruined to various degrees. The third picture in this set of examples only has a minor stripe across the castle at top. After I noticed what was happening, I tried removing the battery, changing the memory card (which was brand new), reformatting the memory card in camera, changing lenses, deleting the settings, switching back and forth from AUTO to MANUAL... nothing helped.  I put the camera back in the bag, and after several hours it was back to normal.

 

This happened again two days later.  I suspect it has something to do with the Florida heat because it always happened later in the day, and after leaving it alone for a while it stopped.

 

Can anyone tell me what might be wrong and what steps to take for repair?  Does anyone have any suggestions on ways to salvage these photos?  I have been an amateur still-learning photographer for the past four years, but I have a degree in graphic design and very advanced at Photoshop and editing. I do not have raw files because I was trying to take so many in the day I wanted to "travel light."

IMG_6269.JPG

 

IMG_6254.JPG

1 ACCEPTED SOLUTION

rs-eos
Elite
Elite

Unfortunately, I don't think you can do any type of full recovery.  You could try experimenting in Photoshop to apply say selective Hue/Saturation adjustments to try to remove a bit of the color casts.   In theory, you could also try to lighten the darker green horizontal stripes by first making a selection with that specific color (but I believe you'll end up having to do a color range instead which will complicate things).

 

In terms of not capturing RAW, I don't think that would've helped since this really sounds like a hardware issue (see below).  But, you really should consider shooting say RAW + JPEG as that would give you a sort of in-camera backup.  If one capture becomes corrupt (e.g. file couldn't be written), you'd have the other format.  Also, higher capacity SDXC cards are now very inexpensive.

 

Finally, to the hardware issue... this really sounds like the camera's electronics are going bad.  Sometimes with older or faulty equipment, the longer the circuitry is on will lead to faults.   As you've found, when the camera was off for a while (circuitry allowed to cool), it then worked again.   You can contact Canon to see about sending in for repair and how much that may cost.

--
Ricky

Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers

View solution in original post

14 REPLIES 14

I also opened one of your images, Cinderella's Castle, in PS. I believe they are unsalvageable. At least without a lot of time consuming work.  I was able to make it very much better with just a simple mask and levels adjustment.  But the underlying issues are going to be difficult to impossible to fix or remove.

 

This leads me to ask, why shutter priority at 1/1600 and f5.6?  Looks like a simple P mode to me.

EB
EOS 1DX and 1D Mk IV and several lenses!

Hey I wanted a fast shutter to capture the movement of the actors without motion blur so I think I was using Shutter Priority setting at the time.  I'm still learning how to take pictures in different scenarios. 

Any settings you would recommend for future similar scenarios are most welcome!  I've been trying to learn the triangle. Sometimes I just end up defaulting to auto because I don't trust my manual selections either.   

" I've been trying to learn the triangle."

 

Yeah, been there done that.  Smiley Happy  Sometime we, beginners, over think the situation. Sometimes a snapshot is still just a snapshot. On my Disney trips I have use several different settings but primarily I just use P mode.  I do like to set ISO at 200 but if movement might be a problem I switch the ISO to 400 or 800. Although it will close the aperture down a bit too it speeds up the shutter also. Stopping down the aperture is generally a good thing as it increase your DOF.  How much is in sharp focus.

I see no need to shoot Raw and jpg.  Choose one or the other. The remote times you might need both is pretty slim to never!  If you have a good post editor, DPP4 from Canon fo rinstance, go ahead and select Raw. It has some advantages over jpg but really only if you post edit.  Otherwise jpg is just fine. Always use several smaller SD cards. Never use big ones, I typically use 16GB but I do have a few 32GB.  Don't use anything over that.  Switch them out during the days hooting so all your shots are not on one SD card.

 

Sorry but I do think your sensor is toast so a new Rebel might be a consideration. Canon refurbs 10% off right now, too!

EB
EOS 1DX and 1D Mk IV and several lenses!

jmquig:

Did you know about this:

Untitled.jpg

It works in P mode. It keeps the exposure the same. Of course, it never seems to go in the direction I want, but it is worth a try. 8^)

John_
Authority

R.I.P ole T3 😞

Time for a new camera or Canon refurb deal. Sell that one "as-is" on an auction site and recover what you can or move to Alaska? 🙂

Avatar
click here to view the press release
Announcements