cancel
Showing results for 
Search instead for 
Did you mean: 

Rebel t6 flash triggering err 20 in auto mode

Theresa1960
Apprentice
wont shoot when in auto mode because it triggers the flash and gives an err 20 on more than one lense.
5 REPLIES 5

John_
Authority

There is a lot of information on that error 20 on the internet, here is one thing to try:

Err 20

Description: A malfunction with the mechanical mechanism has been detected.

Resolution: Turn the power off, then remove and re-install the battery. Then turn the power on again.

I would go one step more, when you have the battery out turn the camera on for about 30 seconds then turn it off, replace the battery and give it a try.

Most other solutions involve servicing of one sort or another.

Theresa1960
Apprentice
Yep we did try it this way but to no avail. I actually took it to a shop about an hour away this morning and he said nothing was wrong with the camera itself and that it had to be in the lense. I brought it back home and rried multiple lenses an it repeated the problem using each of them. My daughter then told me, which I didnt know, she had tried using the camera on nanual mode and it worked fine. So it only errs on auto in low light. Thanks for the reply though.

"I actually took it to a shop about an hour away this morning and he said nothing was wrong with the camera itself and that it had to be in the lense."

 

And, the shop tried their lenses and it worked? Is the flash popping up OK?  If it is slow or doesn't pop up it will trigger an error code.

If the shop had no problem when it used their lenses, that is not a good sign, Kido.  WHat happened to your lenses?

EB
EOS 1DX and 1D Mk IV and several lenses!

Theresa1960
Apprentice
Yep we did try it this way but to no avail. I actually took it to a shop about an hour away this morning and he said nothing was wrong with the camera itself and that it had to be in the lense. I brought it back home and tried multiple lenses and it repeated the problem using each of them. My daughter then told me, which I didnt know, she had tried using the camera on manual mode and it worked fine. So it only errs on auto in low light. Thanks for the reply though.

Does it work in P mode? That is an Auto mode which allows you to make adjustments if you wish or leave it as is

Announcements