Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel T7 display black - got it back on breifly


My camera is a little over a year old.  It appears to still take pictures but I can not confirm it because the display is black.  When I take the memory card out and turn the camera on it shows the no card screen.  So the screen works.

I read through and one of the responses (I think for  t3?) said to take the battery out, turn it on and hold the shutter.


I tried that but it didn't help.  Next I tried it with the battery in.  The screen worked breifly.  But I can't recreate it.  (Which makes no sense.  And I didn't write down what I did.)

I have tried pushing the menu button, the disp button (so many times), checked the bumper around the eye piece.  The shutter button does not appear to be stuck.

I would love any suggestions.  I didn't get the wifi turned off so I am not sure getting an hdmi cable will solve it.




Plug the card into a computer or connect the computer to Wifi, you can at least see if there are pictures on the card.


You can try to get an HDMI cable and plug it into a TV to see if the screen shows up there.


Other than that, you have tried most everything.

Thanks!  I don't connect it to a computer so accessing the screen to conect with wifi is key.


I called Canon.  I told her I tried the hold down the shutter button, and she said creative ideas sometimes work.  Anyway, she didn't have much to try.  But, when the image wouldn't preview through the image finder she said it had to be mailed in.  If anyone wonders, repairs are $90/170/280 plus shipping.  Hopefully it is a minor repair.  


Far from an expert but the over- and underexposure seems to have merit. Go back to default settings and start over?

I have experiemented in the early days with my T7 and came out with white or black photos. Played around with settings and learned a lot. Example: never shoot at water while facing the sun.

Canon EOS T7; EF-S 18-55mm IS; EF 28-135mm IS; EF 75-300mm; Sigma 150-600mm DG

I will try that. Thanks.

Thanks. I will try to find the default settings. But the screen is black for the whole menu so not sure I will get it.