Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Trigger problem


I have the original Canon Digital Rebel. A year or so ago, it developed an issue: It does nothing at all when I press the trigger 1/2 way. When I depress it fully, it does a quick autofocus and then takes the picture.


Looks like a minor thing to fix. Any ideas or suggestions on whether this is fixable by DIY?



I've never shot a Rebel body but all of the Canon DSLR's I have owned had the option to move the AF function to a button on the back. It's done in the menu set so check your manual to see if you've accidently re assigned the function. If you don't have the manual you can download it from Canon.


"A skill is developed through constant practice with a passion to improve, not bought."

Modala do you have the latest firmware installed? Is the first question and if not please try reflashing the firmware and if not then hopefully someone else much more experienced can help you.

Since I was going to trash the camera if it didn't work anyway (I've got a T3i as well), i tried something drastic: I used the tip from the youtube video - and just poured a generous quantity of isopropyl alcohol through the battery area and let it make it's way through the trigger.  (I had taken the battery and memory card out of course).

Let it dry out for an hour or so, and it works.


I wouldn't have got the T3i if I gotten this to work.


I'm selling off the T3i now, and will put the money into a  better lens - the $700 15-85mm one. 🙂

Check out Patrick Norton on the screen savers and he has a tip for using an alcohol based marker pen to clean your lense on your camera. What I was reading about was the Canon's focus mechanism and how it uses a beam in auto focus. I have see. These pens a available at and BH I think before you trash it completely it might do a DYI High School or college kid some good. I have thrown things before out of frustration in not knowing what was wrong with them. I think the pens are like 12.00 bucks for four. Who knows a clean lens means a restored autofocus mechanism and a kid with a 50.00 camera for two months of summer fun :).

@Medic: Just to be clear, I solved the issue that I had with the Digital Rebel (with the trigger not working properly) by pouring some alcohol via the battery compartment so that it went through the trigger.

It was the trigger mechanism that had presumably gotten a little dirty, causing the camera not to work.

It works perfectly now, I think. 🙂