cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Rebel T5i (700D) doesn't power on intermittent

KryptonSvingar
Apprentice

I have a Canon T5i that's just over a year old. It's already been at Canon once for a stuck shutter during warranty. The shutter was replaced under warranty by Canon.

 

Over time, however, I've had another issue. The camera will just not power on. At all. No light from the SD card led when opening and closing the door. Sometimes removing and replacing the battery would help, but licking the battery contacts (tastes nasty, btw) proves to be the most reliable way.  Thinking it was a battery issue, I ordered another battery for it, but it does the same thing, with the same temporary fix working. So...clearly a camera issue.  I've tried updating to FW 1.1.5, but it doesn't resolve the issue.  I've made sure all the doors are closed, etc.

 

The warranty ended in May and I'm worried if I send it off to Canon, it'll work fine when they test it and if not, they'd charge a massive amount of money for OOW repair.  

 

Anyone have any ideas or similar issues.  Tempted to sell all my Canon gear and move to a Nikon, honestly.

main:Canon EOS Rebel T5i 1.1.4
bkup: Canon EOS DIGITAL Rebel XTi 1.1.1
5 REPLIES 5

Waddizzle
Legend
Legend

Check the door to the battery compartment, and likewise for the memory card door.  There are micro-switches on the doors to make sure that they are properly closed.  If the camera thinks the doors are not closed [micro-switches] the camera will not power up.

--------------------------------------------------------
"The right mouse button is your friend."

KryptonSvingar
Apprentice
I've checked both and they are fine.
main:Canon EOS Rebel T5i 1.1.4
bkup: Canon EOS DIGITAL Rebel XTi 1.1.1

I would say to contact Canon support.  An unreliable memory card can cause issues, too, especially micro-SD cards.

--------------------------------------------------------
"The right mouse button is your friend."

KryptonSvingar
Apprentice
Yeah it happens even without a card. I'll see what that have to say.
main:Canon EOS Rebel T5i 1.1.4
bkup: Canon EOS DIGITAL Rebel XTi 1.1.1

i have the same problem with this camera is there any solutions

Avatar
click here to view the gallery
Announcements