cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Eos Rp won't turn on unless removal of battery.

Cjfoo
Apprentice

I recently bought a used Rp and been using for two weeks now the camera is working fine no glitches observed when shooting and the firmware is up to date. But there is this intermittent problem when the camera refused to turn on unless I remove the battery. The initial trigger for this issue is when I tried to change lens on my K&F concept EF to RF mount.I've been trying to reproduce the error here's some observations.

1. Switching lenses, this happened twice but most of the time it's fine. Initial my thought was some contact shorted when removing the lens of my old EF lens on a new KnF concept adapter but so far I have no luck reproducing it with both power on and off. 

2.The error happens again after leaving the camera off for 8 hours after the initial error. I've tried producing the error with and without the initial lens that triggered the issue but so far no luck. 

I've tried a few things  just to see how it effects the camera. 

1. Brushing the contact of the battery with IPA because I've noticed some very minor corrosion. 

2. Turning WiFi off when not in use and  disabled automatic sensor cleaning 

Does anyone experienced similar issue. I am thinking it's the battery although it's original Canon. Due to the fact that breaking the mechanical breaker long enough on the battery compartment doesn't reset the camera or driving the sleep pins high or low when turning the knob. 

1 REPLY 1

Waddizzle
Legend
Legend

Buy a new genuine Canon battery.  Never use IPA on any of the contacts.  Always power down the camera when changing lenses.  If you are using EF mount lenses, then be sure to only use the Canon mount adapter.  Many third party mount adapters cause the cameras to lock up.

--------------------------------------------------------
"The right mouse button is your friend."
National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements