cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon EOS R8 WiFi connection with Android issue

Ak_7
Contributor

Hello, 

I have seen another contribution regarding this but it doesn't answer the real query. 

Issue: after following all the steps to connect android phone to EOS R8 (eos R8) the Bluetooth connection is established but WiFi isnt. Upon trying to connect to the access point of the camera on the phone it says password incorrect.

Have tried all the possible ways (including spending time with a photographer as well as the shop where I bought it).

Have used 6 phones in total for this purpose (2 Google pixels, 2 Samsungs, 1 one plus and another Chinese company). Did all the resets possible. 

Have two other camera (d and m series) .. both connect to the three phones I have at home. The first try within secs.

Side note: Have managed to connect the phone and camera over a shared WiFi but that doesn't help as many times I need to use my camera as a remote outdoors where theres no shared WiFi. Also to transfer pics from camera to phone so I can do basic posting on Instagram or edits.

All this affects my work flow. Pls let me know if I should return the camera? Eos R8 seemed too good to be true anyway.. 😞 

I don't think I can afford a more expensive camera. Though this could be my switch to a full frame. 

Thanks. 

15 REPLIES 15

shadowsports
Legend
Legend

Greetings,

Someone else posted recently about this same issue.  R8, Canon Connect and Android.  I have not been able to reproduce the wi-fi connectivity issues with my body's or phones.  6D2, R5 C, Pixel 6 & 8 and Canon Connect (both wi-fi and bluetooth work for me. 100% of the time. 

The other poster claimed he turned off the password requirement on his camera, making it an open network.  This allowed him to connect.  I don't see why this wouldn't work, its just not something I've had to do.  

~Rick
Bay Area - CA


~R5 C (1.0.6.1) ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

Well I don't even know how would I go about recreating the problem on my other two devices. They never gave me a problem too. Instant connection. 

Anyway, I don't really understand how to disable the password requirement of the camera? Can you pls guide me?

Thanks.

bencarey
Apprentice

I have this exact issue. Canon R8 and Google Pixel 6 using Canon Connect app. Sees the camera using Bluetooth, tries to connect to WiFi, fails. The error message is in the screenshot below. I've tried resetting my connection settings on the camera, deleting and redownloading the app, to no avail. I've resorted to hard-wiring the connection using USB, but even this can be intermittent at times. Quite frustrating. 

On a related note, the app mentioned I have new camera firmware. Given the access issues with WiFi and the app, I am not able to transfer the firmware across. WiFi doesn't work as stated above, and it hangs when connected via usb. I was hoping this firmware update would help this issue, but I can't even update the firmware because of the issue itself. I'll keep preserving with the usb for firmware, or try on the laptop, but I wish I didn't have to. 

1000018357.png

 

Update guys, so I returned the camera and ordered another. Everything through the studio. The new camera has the same issue but there's a catch. We tried with 7 phones on total.. 5 android and 2 iPhones. The camera connected to both iPhones immediately and to none of the androids. So I guess the issue is with the android connectivity.

I hope someone has a solution. It'd be a shame that such a great camera has such an obvious defect. 

Have you contacted phone support so they can walk you through the process? They're at 1-800-OK-CANON (800-652-2666), Monday through Saturday. 

Ak_7,

I use the Camera Connect app on my Android phone, but I use the Camera Connect and Control app on my Android tablet.

The Canon R8 is listed as one of their supported cameras.

You might try that.

Steve Thomas

Thans for this, however the camera connect app on Android is the app that is not allowing a WiFi connection. For those of us without Android tablets this is the only option. The app works on my ipad but if course with the R8 listed as supported in the Android app, it should work. All of my photos are linked to Google photos via my Android device, and the convenience of just using the phone rather than lugging an ipad around is the reason I'm trying to solve this issue. From my end, it's strange that it worked for a few months, and now it doesn't. It makes me think that there may have been some Android update that broke the connection between the Canon app and the camera. Having updated the camera firmware with no solution found, I am assuming canon has not been able to resolve this issue, but it would seem either an app update or firmware update should be the solution. 

Benchley,

I was talking about two different apps. One is made by Canon, and the other is not.

I was just reading through the FAQs of the Camera Connect and Control app and it said that the settings are not transferable between Android and IOS. You have two purchase it twice - once for each operating system.

Steve Thomas

 

Oh right. Didn't realise it was a third party app. I'll give it a go, but in the list of devices it doesn't have the R8 listed, only the R, R5, R6 and RP. But if you're having success I'll try that.

 

Thanks. 

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements