cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

R7 Stuck on Manual Focus

jlf100
Contributor

NMy R7 is stuck on manual focus. I have turned the camera off, removed battery, changed the settings. In the menu (AF - AF operation) only MF is an option.  I've read of at least one other person with this issue who had to factory reset. Do I have any other options? 

12 REPLIES 12

jimhsia
Apprentice

Yup, I ran into this issue last month. For me, it was changing the AF-MF switch to AF on the front of the camera. Too bad the setting doesn't show up on the menus.

Canon R7.jpg

Oh, my - such a simple fix! Thanks so much. 

LloydSully
Apprentice

Using a new Canon R7. Autofocus was working fine in the morning with a Canon 18-135mm IS USM lens and Neewar adapter. It had worked fine ever since I got the camera. This afternoon I took the lens and adapter off the camera body to check the fit of a new padded lens pouch. When I put the lens back on the body, adapter already attached, the lens was not fully seated into the adapter. I fixed that problem and I had autofocus again as before. 

National Parks Week Sweepstakes style=

Enter for a chance to win!

April 20th-28th
Announcements