Showing results for 
Show  only  | Search instead for 
Did you mean: 

R5 Freezing up After Firmware 1.5 Update...


I've heard this is an issue, and I experienced it yesterday while shooting some birds. My R5 locked up about 5 times in a row during one session. Each time I took the battery out and it froze repeatedly. Eventually it stopped, but I was not too pleased. Are others having this issue, is canon going to fix it, and is there a way to go back to version 1.4 as an interim solution?



I have had similar problems with an R5 with battery extender while using my 100-500mm ever since I upgraded to firmware 1.5. I am using AI Servo at the time with '*' Set to Eye focus and 'AF ON' set to focus. This problem happens consistently when I am watching a bird for a while and take my finger off the eye focus back button "*" on my camera. I consistently get a crash when the bird starts to move, I press the eye focus. The key is a pause of at least 5 minutes. One work around is the hit the AF On button (Set to focus) first. At one point I made the AF On button my eye focus button, same result. I have tried all the above suggestions with no luck at all. The issue does NOT happen when using any other lens. I had a friend out with me yesterday who had similar problems and then they stopped when he changed his crop factor on the red menu 1. Now no more issues. Try it, since you are probably shooting birds the crop helps. Canon Needs to fix the firmware.

View solution in original post


I got the R5 in early December. I shoot high school sports and the R5 was regularly freezing on me once a game.

Prior to the last to games, I started low level formatting the CF Express card in the camera. So far, I haven’t had a single freeze since I’ve started doing that. 

FWIW, low-level formatting didn't fix the issue for me.

Product Expert
Product Expert

Hello cohenfive,

I'm sorry to hear your EOS R5 is freezing and to see that other posters are seeing the issue as well. When a camera is freezing there are a couple of things to check. Sometimes if something attached to the camera is malfunctioning it can cause it to freeze up. 

First try replacing the battery to see if the same thing happens. If the freezing continues try swapping in new memory cards. If that doesn't resolve the issue try attaching a different lens. If the freezing stops after swapping out one of those pieces it indicates that was the cause of the freezing. If the issue continues after swapping out those pieces that is a sign there is an issue with the camera. In that case we would recommend sending the camera in for repair.



Hazel thanks for the note. The issue is not a memory card or battery or lens. The issue is becoming well documented now by many canon r5/6 owners. Sending the camera in for repair is a statement that there is something wrong with the firmware. Canon needs to fix the firmware rapidly and if anyone is forced to send their camera in, Canon should cover any and all expenses related to that process regardless of warranty status of the camera. This is not the fault of the camera owners, it is bad software released by Canon.

I’ve had multiple freeze occurrences.  I largely followed the advice above, then sent my brand new camera in for service.  I’ve been told there’s no issue with camera - maybe it’s my brand new RF adapter.  If it happens again, send in the whole setup.  I’m not happy.  

That's very annoying indeed, sorry to hear that.
FWIW, my camera has locked up with RF lenses (so without adapter) as well.


I responded to Niccole above about resetting the camera. At least that worked for me, and could be considered as an option to try before sending the camera back to Canon.


Just updated  R5 to ver 1.5- multiple freeze ups- never occurred prior to this update. Multiple users on FM  Canon forum with similar posts. I tried both methods posted for reverting back to 1.4 but was unsuccessful. Canon customer service claims only Canon service can revert firmware. Camera is on its way to Costa Mesa with Canon pre-paid UPS label. This is not good PR for an expensive new rig. R6 having same issues with this update


I use 2 Canon EOS R5's.

A couple of days ago I did a shoot with only 1 of these camera's. It locked up about 10-15 times in a 4 hour shoot. Removing the battery solves the issue for a (short) while. Waiting for about half a minute seems to make the camera operational as well.

I can't have this behavior when I'm on a high paced assignment like a wedding. So I "downgraded" this camera to 1.4.0. I'm keeping the other one (the older one) on 1.5.0 to see if it's bound to the camera or not.

Prior to the downgrade I contacted Canon CPS (Belgium) about this. None of my questions were answered, their reply was "send it in". I'm not going to do that.

Low-level formatting the CF Express cards didn't help for me. I'll try formatting both cards (CFE and SD) after the next lockup.


May I ask how everyone is charging their batteries, USB in camera or wall charger with the battery pulled? Grip or no grip? I just started to charge via USB and my R5 froze for a few seconds today then unfroze itself and began working fine. 

click here to view the gallery