Showing results for 
Show  only  | Search instead for 
Did you mean: 

Noob: EOS R7 won't connect to EOS Utility 3 after firmware update


I just picked up my first Canon EOS camera and just getting going. It's the R7.
I have a 2020 5K iMac (Intel CPU), running Ventura 13.5.2 I'll use for photo editing.

Part of setting up was using the EOS Utility 3 tool to update the firmware on the camera, which worked fine.
However, after the update, EOS Utility would not connect to the camera.
Here's the error message:
Screenshot 2023-09-21 at 12.24.35 PM.png

After joining the Forum and doing a lot of searching, I managed to turn off WiFi on the camera and made sure there were no backup/sync tools like Google Backup running, but still no connection.

Ultimately, I figured it out by rebooting the iMac. Now the camera and computer connect just fine using EOS Utility 3.
I'm close to retirement after 36 years in software development and support business for both Windows and Mac. You would think restarting this frackin' Mac would be high on my troubleshooting list, but no, not this time.

So if you're having communication problems with your camera and Mac, keep restarting in your tool bag.

John B


Not applicable

Good advice. Thanks for sharing it.


I am a retired software engineer. My iMac is enough like my Linux computers and the Unix computers I used to work on that I cannot imagine a reboot being needed unless a new kernel is installed, but it occasionally seems useful to reboot the iMac.

click here to view the gallery