Showing results for 
Show  only  | Search instead for 
Did you mean: 

My Canon 6D mk2 will not format CARD


I have four SD cards, Sandisk of various stripes, 128 through 16G.  Today when I went to the camera I got the "can't access card, format card or change card" message. No ERR, just that.  I've done all the possible research and haven't found a solution yet.  I can try buying a new card but why would that work?  I've had the camera a few weeks and really fell in love with it  Dang! Win 10 Home Pro 24G RAM, Gigabyte Mobo, i5 CPU. Help!  There are older posts on this board but they haven't helped me.






Welcome to the forum.


Not clear from your post - does this happen with all four cards?

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic


Is the card slot perhaps damaged?  Are its contacts clean?


Camera: EOS 5D IV, EF 50mm f/1.2L, EF 135mm f/2L
Lighting: Profoto Lights & Modifiers


Also make sure the card(s) are not locked or write protected.

Bay Area - CA

~R5 C ( ~RF Trinity, ~RF 100 Macro, ~RF 100~400, ~RF 100~500, +RF 1.4x TC, +Canon Control Ring, BG-R10, 430EX III-RT ~DxO PhotoLab Elite ~DaVinci Resolve ~Windows11 Pro ~ImageClass MF644Cdw/MF656Cdw ~Pixel 8
~CarePaks Are Worth It

There was damage to the card slot, a broken pin.

I did get a full refund from eBay,so there's that.  AND I have a functioning 6D Mk 2, which is a lovely FF camera.

I am glad that you got your money back, ebay is very good about that making it quite safe for buyers.


The SD card interface is far more robust than the tiny pins of a CF card socket connector but even SD card sockets can be damaged. The previous owner probably made a mistake and tried to force fit a card that wasn't going in properly or bought a poor counterfeit card where the dimensions weren't quite correct.



EOS 1DX M3, 1DX M2, 1DX, 5DS R, M6 Mark II, 1D M2, EOS 650 (film), many lenses, XF400 video


You have Windows so try to format the SD cards on your Windows machine. I am not sue a Mac will work but it might. If they format on your Windows computer the SD cards are probably OK.


About all you can do is check the interlock is not set to on, on the SD cards. Probably a good idea to reset the camera too. Menus, tools, clear all settings and clear all custom settings. Its pretty difficult to damage the SD pins in a 6D Mk II or any SD camera for that matter but it can be done.


BTW, a new SD card is always a good idea. Makes sure it isn't Dollar General/Walmart/Amazon cheapo house brand.


"I've had the camera a few weeks and really fell in love with it..."


Pretty easy to do Smiley Happy but it should be under Canon warranty so if it is a faulty camera they will fix it.

EOS 1DX and 1D Mk IV and less lenses then before!

Thanks for your replies.  I"m going quietly nuts.  All four cards show this error.  All Sandisk, and they have worked in this camera and in previous  cameras.  Right now I"m doing the fulllll and Very Slow format of a 64G Sandisk Extreme.  This is going to take a while.  I'm also going to buy a new SD card, name brand, asap. Somehow I think it's the cards and not the camera.  Something happened on my computer.  I recently installed Pshop 21 and both versions of Lightroom (plus Classic) and for no reason I suspect something in the software department fouled my cards. NO interlock.  I only wish it were that simple.

The default ffile format is exFAT, just clicked on device default. Not FAT32?
click here to view the gallery