Showing results for 
Show  only  | Search instead for 
Did you mean: 

MacBook Pro is no longer detecting EOS Rebel T7i after macOS Sonoma v14 update


MacBook Pro is no longer detecting EOS Rebel T7i after macOS Sonoma v14 update. Prior to the update, my computer to include zoom, teams, and Streamyard worked well. Need help.


Product Expert
Product Expert

Hi dietfreelife,

Prior to the update were you using our EOS Webcam Utility to use your camera as a webcam? If you were using it that software hasn't been updated for OS14 Sonoma yet, so it might not run correctly on that operating system. At this time there has not been an announcement for when an updated version may be available.

In the meantime you could try installing the OS13 version of the software. You can do that HERE. Once you are on the web page click on the Software & Drivers button and there will be an operating system drop down. Click on the operating system drop down and select macOS Ventura v13. The current version of the software is EOS Webcam Utility Pro 2.0.30. 

Once that is installed or updated connect your camera and computer with a USB cable, open your streaming or conferencing service, and when you go to select the camera there will be an option for EOS Webcam Utility. Select that and it will start using the video feed from your camera.

If the issue continues the first thing to double check is to make sure the camera is in Movie mode. If it is in one of the photography modes sometimes it is not detected as a webcamera.

Another thing is to make sure the wifi on the camera is turned off. When wifi is enabled on the EOS Rebel T7i it turns off the USB port. To check that press the wifi button on the camera, select Wi-Fi Settings, and on the next page set Wi-Fi to Disable. Once you've done that check to see if the same thing happens.

If the issue continues the next thing would be to try a different USB cable. When you try a different cable it would be good to try a different USB port if your camera has another one. If you need a new cable the EOS Rebel T7 uses a Mini-B to Type-A USB cable. That is a standardized cable type that should be available in most electronics stores and online electronics retailers.

Another thing to try would be to restart the computer using the restart option in the operating system. If there are pending operating system updates we would recommend allowing those to go through. Sometimes if there is a stuck process running in the background or a pending operating system update it can cause issues like this.

This has been very helpful. Thank you. Unfortunately, I have checked everything you suggested. Prior to this update, everything worked fine. I guess I have to wait until there's an update with Canon or get another camera.  

click here to view the press release