Showing results for 
Show  only  | Search instead for 
Did you mean: 

MY EOS 30D works just fine until I put it on a tripod, then it won't take pictures. Any ideas?


I have had my 30D for some time now, and it has worked flawlessly.  Today, I tried mounting it to a tripod to take some pictures.  It will not release the shutter.  If I press the shutter release button, the indicators in the viewfinder all light up as usual, but the shutter will not release.  If I activate the built in flash, pressing and holding the shutter release eventually causes the flash to blink as though in red-eye prevention mode, but the shutter will not release at all.  Pressing the * button results in the flash firing.


The tripod is a Manfrotto model, which I have also had for some time and am using for the first time.  The lens is a zoom tnat came with the camera.  The camera is mounted mechanically to the tripod using a quick-release adaptor, also a Manfrotto product.  The quick release adaptor has been on the cemera for some time, and it has operated flawlessly until I mounted it on the tripod today.


There are no electrical connections that I am aware of between the tripod and the camera, unless there's some hidden feature of which I am unaware.  I have no remote shutter release, but planned to use the timed shutter release setting.  Both the timed and normal modes work flawlessly when the camera is hand-held, both modes work flawlessly, but when the camera is on the tripod, it won't take a picture.  I am flummoxed by this.  Neither the camera manual nor the Manfrotto tripod manual are any help.


Any ideas?




Jim Carroll




We just wanted to let you know that we don't recommend do-it-yourself repairs. So, if you’re experiencing a problem with your EOS 30D, it’s best to let a professional Canon Factory Service Center Technician do the work to keep you and your gear safe.


You can reach out to our friendly, U.S.-based support team at for some troubleshooting steps, and they can let you know the steps for service is necessary.



View solution in original post



It probably is not focusing.  Make sure you have it on the green square and the lens switch set to AF.  Try again.

EOS 1DX and 1D Mk IV and less lenses then before!

Green square, lens set to AF, bright room lighting.  Off tripod, functions normally.  On tripod, will not release shutter and take a photo.  I'm still stumped.  



If flash is blinking like that it sounds like it is too dark for camera to focus; thats the focus assist. Are you in a dark shooting situation?

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

The ambient iight is bright enough to take a picture without flash.  Again, when hand-held, functions exactly as it always has. On the tripod, it won't take a photo.

Long shot, do you have your eye on the viewfinder on the tripod? Try putting on the viewfinder cover.

could the weight of the lense when not being held make it loose contact maybe?


Not likely if camera and lens don't have faulty components. He could test that by taking camera off tripod and trying to shoot without holding lens.


kvbarley's idea has merit since bright light coming in through the viewfinder could fool camera into overxposure and then shutter wouldn't fire. The rapidly firing flash points to a focus problem though. Are you pointing at the same subject on and off tripod.

John Hoffman
Conway, NH

1D X Mark III, M200, Many lenses, Pixma PRO-100, Pixma TR8620a, Lr Classic

If the lens has Image Stabilization, you should probably turn it off when using a tripod.

"The right mouse button is your friend."

I came across a problem when the same generation 5D was mounted on a tripod and the rear LCD started to show pictures of weird polarized effect.


Screwing on the tripod mount will result some pressure to the base plate of the camera causing misbehaviour  on some electronic connections inside.


If you are brave enough, open up the rear panel of the camera and investigate. I believe it is only 6 screws and 2 ribbon cables to remove. It is pretty straight forward. There is one youtube tutorial about 40D and thery are similar. I even replaced the LCD of 40D and tightened up cable connection of 5D. They worked perfectly after the surgery.


A simplier fix will be adding a rubber ring between the tripod screw and the camera base plate. Thus shorten the screw into the mount thread. Or you may DIY to shorten the screw of the mount plate. Or insert a few mm rubber piece into the camera screw hole. A shorter screw into the camera will definitely reduce the pressure of the base plate and hopefully the electronic connection will not be affected. (But make sure that the camera is secure and will not fall from the shorten screw)


Just my 2 cents. Do so at your own risk.


The cost of repair of a 30D is possibly equivalent to buying 2 X 30D.

click here to view the gallery