Showing results for 
Show  only  | Search instead for 
Did you mean: 

M6 MarkII - Macbook Pro - USB not working




I have been having a trouble using my M6 MarkII on a Macbook Pro. I am connecting over USB-C and have installed the corresponding Webcam Utility from Canon website.


Based on the suggestions from other forum messages, I have ensured that "WiFi" and "Bluetooth" are disabled in my camera. Still no luck. 


The same camera works fine on my Windows PC. 


Any other suggestions?






With a MacBook Pro I assume that you are using a port adapter.  That would be my prime suspect.

"The right mouse button is your friend."

Yes, I am using CalDigit docking station on both PC and Mac. Do you think that it could cause problem only in Macbook pro?


When I power on and off, EOS Utility does recognize that and brings up a dialog box (preferences) but none of the other applications recognize it though. 


I will try without the docking station.

Problem solved. 


No issues with the interface cable or adapter or the docking station. Closing Google Drive Sync app fixed the problem. 


My setup for anyone else looking for an answer:


1) M6 Mark II

2) Macbook Pro

3) Catalina 10.15.7

4) Using CalDigit Docking Station (also Apple USB-C Digital AV Multiport Adapter)


If you have any other app like Dropbox sync running in the background, that could also be interferring with EOS webcam utility.