cancel
Showing results for 
Search instead for 
Did you mean: 

Lens fogged and now shutter is slow?

aheiser
Apprentice

I have a Rebel t3i camera. Yesterday I went to use it and the lens was fogged. After wiping it off, it worked for a few pictures but then the shutter became very slow and the pictures became blurry. I only use the manual settings (Landscape, portrait, sports, etc). I tried it again today and it still sounds as though the shutter is working quite slow and the pictures are terrible!

I switched lenses and the result is the same.

Any suggestions? 

3 REPLIES 3

wq9nsc
Authority

How is the view through the viewfinder?  Is it clear and is the lens focusing properly?  

 

Try placing the mode dial in the full auto setting and take some test shots to rule out other settings that were accidentally changed during the fogging issue.

 

I don't know how well sealed the your T3i is but it is possible that the mirror and sensor were also fogged when the cold camera and lens were introduced into a warmer/humid environment and any debris/film buildup on those would have been made worse by their moisture exposure.  It may need to be cleaned at a reputable dealer location.  Although the sensor can be exposed for cleaning (instructions are in the manual) UNLESS you are very careful and skilled it is easy to damage this expensive part so if an examination reveals that the mirror or sensor needs cleaning I would use Canon service for this step.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video

ebiggs1
Legend

A good guess is whatever fogged the lens also fogged the Rebel.  I doubt Canon services the T3i any longer but you might try calling and see. You can try all the easy stuff first. New battery, charger, SD card, resetting the camera to factory, etc.

 

 

"I only use the manual settings (Landscape, portrait, sports, etc)"

These are not 'manual settings', BTW.  Manual is set with "Manual mode" on the dial. The camera sets nothing then.

EB
EOS 1DX and 1D Mk IV and several lenses!

JonKline
Enthusiast

Please post a sample picture with exif data so we can help diagnose the problem.

______________________________
I'm a cinematographer in Chicago using mostly Canon gear. I also founded MKE Production Rental in Milwaukee.
Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM